]> git.pld-linux.org Git - packages/perl-RPM-Specfile.git/blob - perl-RPM-Specfile.spec
- should be ready for perl-5.8.0; release++
[packages/perl-RPM-Specfile.git] / perl-RPM-Specfile.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    RPM
7 %define pnam    Specfile
8 Summary:        RPM::Specfile - Perl extension for creating RPM Specfiles
9 Summary(pl):    RPM::Specfile - rozszerzenie Perla do tworzenia plików spec dla RPM-a
10 Name:           perl-%{pdir}-%{pnam}
11 Version:        1.11
12 Release:        2
13 License:        ?
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Simple module for creation of RPM Spec files. Used by cpanflute2 to
23 turn CPAN tarballs into RPM modules. See the included script
24 cpanflute2 for usage; documentation coming soon.
25
26 %description -l pl
27 Prosty modu³ do tworzenia plików .spec dla RPM-a. Jest u¿ywany przez
28 cpanflute2 do zamiany paczek CPAN na modu³y RPM. Sposób u¿ycia mo¿na
29 znale¼æ w za³±czonym skrypcie cpanflute2 - dokumentacja wkrótce.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor 
37 %{__make}
38
39 %{!?_without_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
44
45 %{__make} install DESTDIR=$RPM_BUILD_ROOT
46 mv $RPM_BUILD_ROOT%{_bindir}/cpanflute2 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %{perl_vendorlib}/%{pdir}/*.pm
55 %{_mandir}/man3/*
56 %dir %{_examplesdir}/%{name}-%{version}
57 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.044778 seconds and 3 git commands to generate.