]> git.pld-linux.org Git - packages/perl-PerlIO-utf8_strict.git/blob - perl-PerlIO-utf8_strict.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-PerlIO-utf8_strict.git] / perl-PerlIO-utf8_strict.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    PerlIO
6 %define         pnam    utf8_strict
7 Summary:        PerlIO::utf8_strict - Fast and correct UTF-8 IO
8 Name:           perl-%{pdir}-%{pnam}
9 Version:        0.007
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  9e8fba7f15c612c4f2ed2f961bf1141b
16 URL:            http://search.cpan.org/dist/PerlIO-utf8_strict/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module provides a fast and correct UTF-8 PerlIO layer.
23 Unlike perl's default :utf8 layer it checks the input for correctness.
24
25 %prep
26 %setup -q -n %{pdir}-%{pnam}-%{version}
27
28 %build
29 %{__perl} Makefile.PL \
30         INSTALLDIRS=vendor
31 %{__make}
32
33 %{?with_tests:%{__make} test}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 %{__make} install \
39         DESTDIR=$RPM_BUILD_ROOT
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc Changes
47 %{perl_vendorarch}/PerlIO/utf8_strict.pm
48 %dir %{perl_vendorarch}/auto/PerlIO/utf8_strict
49 %attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/utf8_strict/*.so
50 %{_mandir}/man3/*
This page took 0.075042 seconds and 4 git commands to generate.