]> git.pld-linux.org Git - packages/perl-Path-Class.git/blob - perl-Path-Class.spec
- pl
[packages/perl-Path-Class.git] / perl-Path-Class.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "./Build test"
4                         # (tests fail because our perl doesn't contain
5                         # File::Spec::Win32 and other "foreign" modules)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define pdir    Path
9 %define pnam    Class
10 Summary:        Cross-platform path specification manipulation
11 Summary(pl):    Wieloplatformowe operacje na ¶cie¿kach plików
12 Name:           perl-Path-Class
13 Version:        0.03_01
14 Release:        1
15 # same as Perl
16 License:        GPL or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/authors/id/K/KW/KWILLIAMS/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  d5531392cd65c9221e21627ef8dab2a2
20 Patch0:         %{name}-test-bareword.patch
21 BuildRequires:  perl-Module-Build >= 0.20
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Path::Class is a module for manipulation of file and directory
29 specifications (strings describing their locations, like
30 '/home/ken/foo.txt' or 'C:\Windows\Foo.txt') in a cross-platform
31 manner. It supports pretty much every platform Perl runs on, including
32 Unix, Windows, Mac, VMS, Epoc, Cygwin, OS/2, and NetWare.
33
34 The well-known module File::Spec also provides this service, but it's
35 sort of awkward to use well, so people sometimes avoid it, or use it
36 in a way that won't actually work properly on platforms significantly
37 different than the ones they've tested their code on.
38
39 %description -l pl
40 Path::Class to modu³ do operacji na specifikacjach plików i katalogów
41 (³añcuchach opisuj±cych ich po³o¿enie, takich jak '/home/ken/foo.txt'
42 czy 'C:\Windows\Foo.txt') w sposób wieloplatformowy. Obs³uguje
43 wiêkszo¶æ platform na których dzia³a Perl, w tym: Unix, Windows, Mac,
44 VMS, Epoc, Cygwin, OS/2, NetWare.
45
46 Podobne operacje s± udostêpniane przez dobrze znany modu³ File::Spec,
47 ale jest on nieco niewygodny, wiêc ludzie czasem go unikaj± lub
48 u¿ywaj± w sposób nie dzia³aj±cy poprawnie na platformach znacz±co
49 ró¿nych od tych, na których testuj± kod.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p1
54
55 %build
56 %{__perl} Build.PL \
57         installdirs=vendor \
58         destdir=$RPM_BUILD_ROOT
59
60 ./Build
61 %{?with_tests:./Build test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 ./Build install
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes
74 %{perl_vendorlib}/Path
75 %{_mandir}/man3/*
This page took 0.088568 seconds and 3 git commands to generate.