]> git.pld-linux.org Git - packages/perl-Path-Class.git/blob - perl-Path-Class.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Path-Class.git] / perl-Path-Class.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "./Build test"
4                         # (tests fail because our perl doesn't contain
5                         # File::Spec::Win32 and other "foreign" modules)
6
7 %define         pdir    Path
8 %define         pnam    Class
9 Summary:        Path::Class - cross-platform path specification manipulation
10 Summary(pl.UTF-8):      Path::Class - wieloplatformowe operacje na ścieżkach plików
11 Name:           perl-Path-Class
12 Version:        0.37
13 Release:        1
14 # same as perl 5
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-authors/id/K/KW/KWILLIAMS/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  13e6db714f6d5a0e62ca1c4a7fc4d0f3
19 URL:            http://search.cpan.org/dist/Path-Class/
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
21 BuildRequires:  perl-Module-Build >= 0.3601
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 BuildRequires:  perl(File::Spec) >= 3.26
26 BuildRequires:  perl-File-Temp
27 BuildRequires:  perl-Test-Simple
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Path::Class is a module for manipulation of file and directory
34 specifications (strings describing their locations, like
35 '/home/ken/foo.txt' or 'C:\Windows\Foo.txt') in a cross-platform
36 manner. It supports pretty much every platform Perl runs on, including
37 Unix, Windows, Mac, VMS, Epoc, Cygwin, OS/2, and NetWare.
38
39 The well-known module File::Spec also provides this service, but it's
40 sort of awkward to use well, so people sometimes avoid it, or use it
41 in a way that won't actually work properly on platforms significantly
42 different than the ones they've tested their code on.
43
44 %description -l pl.UTF-8
45 Path::Class to moduł do operacji na specifikacjach plików i katalogów
46 (łańcuchach opisujących ich położenie, takich jak '/home/ken/foo.txt'
47 czy 'C:\Windows\Foo.txt') w sposób wieloplatformowy. Obsługuje
48 większość platform na których działa Perl, w tym: Unix, Windows, Mac,
49 VMS, Epoc, Cygwin, OS/2, NetWare.
50
51 Podobne operacje są udostępniane przez dobrze znany moduł File::Spec,
52 ale jest on nieco niewygodny, więc ludzie czasem go unikają lub
53 używają w sposób nie działający poprawnie na platformach znacząco
54 różnych od tych, na których testują kod.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Build.PL \
61         installdirs=vendor \
62         destdir=$RPM_BUILD_ROOT
63
64 ./Build
65 %{?with_tests:./Build test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 ./Build install
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %dir %{perl_vendorlib}/Path
79 %{perl_vendorlib}/Path/Class.pm
80 %{perl_vendorlib}/Path/Class
81 %{_mandir}/man3/Path::Class*.3pm*
This page took 0.215668 seconds and 4 git commands to generate.