]> git.pld-linux.org Git - packages/perl-POE-Component-IRC.git/blob - perl-POE-Component-IRC.spec
- updated to 6.12
[packages/perl-POE-Component-IRC.git] / perl-POE-Component-IRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Component-IRC
8 Summary:        POE::Component::IRC - a fully event-driven IRC client module
9 Summary(pl.UTF-8):      POE::Component::IRC - moduł w pełni sterowanego zdarzeniami klienta IRC
10 Name:           perl-POE-Component-IRC
11 Version:        6.12
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  db28b438ce523308ee12d0a21736502f
18 URL:            http://search.cpan.org/dist/POE-Component-IRC/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(POE::Component::Pluggable) >= 1.24
23 BuildRequires:  perl-POE >= 0.3202
24 BuildRequires:  perl-POE-Component-Client-DNS >= 1:0.99
25 BuildRequires:  perl-POE-Filter-IRCD >= 1.7
26 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 POE::Component::IRC is a POE component (who'd have guessed?) which
33 acts as an easily controllable IRC client for your other POE
34 components and sessions. You create an IRC component and tell it what
35 events your session cares about and where to connect to, and it sends
36 back interesting IRC events when they happen. You make the client do
37 things by sending it events. That's all there is to it. Cool, no?
38
39 %description -l pl.UTF-8
40 POE::Component::IRC to komponent POE (któżby zgadł?), który
41 funkcjonuje jako łatwo sterowalny klient IRC dla innych komponentów i
42 sesji POE. Tworzy się komponent IRC i mówi mu, którymi zdarzeniami
43 zajmuje się sesja oraz gdzie ma się połączyć, a on wysyła z powrotem
44 interesujące zdarzenia IRC, kiedy wystąpią. Poprzez wysyłanie zdarzeń
45 powoduje się, że klient wykonuje różne rzeczy. To wszystko, co trzeba
46 zrobić. Fajnie, nie?
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT%{_examplesdir}
66 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README docs/*
74 %{perl_vendorlib}/POE/Component/IRC.pm
75 %dir %{perl_vendorlib}/POE/Component/IRC
76 %{perl_vendorlib}/POE/Component/IRC/*.pm
77 %dir %{perl_vendorlib}/POE/Component/IRC/Plugin
78 %{perl_vendorlib}/POE/Component/IRC/Plugin/*.pm
79 %dir %{perl_vendorlib}/POE/Component/IRC/Qnet
80 %{perl_vendorlib}/POE/Component/IRC/Qnet/*.pm
81 %{perl_vendorlib}/POE/Filter/IRC.pm
82 %dir %{perl_vendorlib}/POE/Filter/IRC
83 %{perl_vendorlib}/POE/Filter/IRC/Compat.pm
84
85 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
86 %{_mandir}/man3/*
This page took 0.067818 seconds and 3 git commands to generate.