]> git.pld-linux.org Git - packages/perl-PAR-Dist.git/blob - perl-PAR-Dist.spec
- initial revision
[packages/perl-PAR-Dist.git] / perl-PAR-Dist.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PAR
7 %define pnam    Dist
8 Summary:        Create and manipulate PAR distributions
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.05
11 Release:        1
12 License:        Same as Perl itself
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 URL:            http://par.perl.org
16 BuildRequires:  perl-devel >= 5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module creates and manipulates PAR distributions.  They are archi-
23 tecture-specific PAR files, containing everything under blib/ of CPAN
24 distributions after their "make" or "Build" stage, a META.yml describ-
25 ing metadata of the original CPAN distribution, and a MANIFEST detail-
26 ing all files within it.  Digitally signed PAR distributions will also
27 contain a SIGNATURE file.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36 %{!?_without_tests:%{__make} test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changes README
50 %dir %{perl_vendorlib}/PAR
51 %{perl_vendorlib}/PAR/*.pm
52 %{_mandir}/man3/*
This page took 0.03137 seconds and 3 git commands to generate.