]> git.pld-linux.org Git - packages/perl-PAR-Dist.git/blob - perl-PAR-Dist.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-PAR-Dist.git] / perl-PAR-Dist.spec
1 #
2 # Conditional build:
3 %bcond_without  test # do not perform "make test"
4 #
5 %define         pdir    PAR
6 %define         pnam    Dist
7 Summary:        PAR::Dist - create and manipulate PAR distributions
8 Summary(pl.UTF-8):      PAR::Dist - tworzenie i manipulacja dystrybucjami PAR
9 Name:           perl-PAR-Dist
10 Version:        0.49
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/PAR/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bd852113974544f3c8c107ab4055cf8c
17 URL:            http://par.perl.org/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module creates and manipulates PAR distributions.  They are
25 architecture-specific PAR files, containing everything under blib/ of
26 CPAN distributions after their "make" or "Build" stage, a META.yml
27 describing metadata of the original CPAN distribution, and a MANIFEST
28 detailing all files within it.  Digitally signed PAR distributions
29 will also contain a SIGNATURE file.
30
31 %description -l pl.UTF-8
32 Ten moduł tworzy i manipuluje dystrybucjami PAR. Są one zależnymi od
33 architektury plikami PAR. Zawierają wszystko to, co znajduje się
34 w katalogu blib/ dystrybucji CPAN po wykonaniu etapu "make" lub
35 "Build", plik META.yml opisujący metadane pierwotnej dystrybucji CPAN
36 oraz plik MANIFEST zawierający listę plików. Podpisane cyfrowo
37 dystrybucje PAR zawierają dodatkowo plik SIGNATURE.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/PAR/Dist.pm
62 %{_mandir}/man3/PAR::Dist.3pm*
This page took 0.068942 seconds and 4 git commands to generate.