]> git.pld-linux.org Git - packages/perl-PAR-Dist.git/blob - perl-PAR-Dist.spec
- md5
[packages/perl-PAR-Dist.git] / perl-PAR-Dist.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PAR
7 %define pnam    Dist
8 Summary:        Create and manipulate PAR distributions
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.05
11 Release:        1
12 License:        Same as Perl itself
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  899b3dd6118ab71eec416d65dfcdc113
16 URL:            http://par.perl.org
17 BuildRequires:  perl-devel >= 5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module creates and manipulates PAR distributions.  They are archi-
24 tecture-specific PAR files, containing everything under blib/ of CPAN
25 distributions after their "make" or "Build" stage, a META.yml describ-
26 ing metadata of the original CPAN distribution, and a MANIFEST detail-
27 ing all files within it.  Digitally signed PAR distributions will also
28 contain a SIGNATURE file.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37 %{!?_without_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %dir %{perl_vendorlib}/PAR
52 %{perl_vendorlib}/PAR/*.pm
53 %{_mandir}/man3/*
This page took 0.022895 seconds and 3 git commands to generate.