]> git.pld-linux.org Git - packages/perl-Math-FFT.git/blob - perl-Math-FFT.spec
- release 9 (by relup.sh)
[packages/perl-Math-FFT.git] / perl-Math-FFT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    FFT
8 Summary:        Math::FFT - Perl module to calculate Fast Fourier Transforms
9 Summary(pl.UTF-8):      Math::FFT - moduł Perla do obliczania szybkiej transformaty Fouriera
10 Name:           perl-Math-FFT
11 Version:        1.28
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  de12537d06eb90e8a4d80b765ceb8252
18 URL:            http://search.cpan.org/dist/Math-FFT/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module implements some algorithms for calculating Fast Fourier
25 Transforms for one-dimensional data sets of size 2^n.
26
27 %description -l pl.UTF-8
28 Ten moduł zawiera implementacje algorytmów do obliczania szybkiej
29 transformaty Fouriera dla jednowymiarowych zbiorów danych rozmiaru
30 2^n.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorarch}/Math/FFT.pm
58 %dir %{perl_vendorarch}/auto/Math/FFT
59 %attr(755,root,root) %{perl_vendorarch}/auto/Math/FFT/FFT.so
60 %{_mandir}/man3/*
This page took 0.06503 seconds and 4 git commands to generate.