]> git.pld-linux.org Git - packages/perl-MasonX-Interp-WithCallbacks.git/blob - perl-MasonX-Interp-WithCallbacks.spec
- turned off tests
[packages/perl-MasonX-Interp-WithCallbacks.git] / perl-MasonX-Interp-WithCallbacks.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    MasonX
7 %define pnam    Interp-WithCallbacks
8 Summary:        MasonX::Interp::WithCallbacks - Mason callback support via Params::CallbackRequest
9 Summary(pl):    MasonX::Interp::WithCallbacks - obs³uga callbacków Masona poprzez Params::CallbackRequest
10 Name:           perl-MasonX-Interp-WithCallbacks
11 Version:        1.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  0f0fa00e6a5d2c5318ad48ef9cea3705
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Container >= 0.09
22 BuildRequires:  perl-HTML-Mason >= 1.23
23 BuildRequires:  perl-Params-CallbackRequest >= 1.11
24 BuildRequires:  perl(Test::Simple) >= 0.17
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 MasonX::Interp::WithCallbacks subclasses HTML::Mason::Interp
31 in order to provide a Mason callback system built on
32 Params::CallbackRequest. Callbacks may be either code references
33 provided to the new() constructor, or methods defined in subclasses of
34 Params::Callback. Callbacks are triggered either for every request or
35 by specially named keys in the Mason request arguments, and all
36 callbacks are executed at the beginning of a request, just before
37 Mason creates and executes the request component stack.
38
39 %description -l pl
40 MasonX::Interp::WithCallbacks jest podklas± HTML::Mason::Interp
41 dostarczaj±c± Masonowi system wywo³añ zwrotnych (callbacków) zbudowany
42 w oparciu o Params::CallbackRequest. Callbacki mog± byæ referencjami
43 do kodu przekazanymi do konstruktora new() lub metodami zdefiniowanymi
44 w podklasach Params::Callback. Wywo³ania zwrotne s± wyzwalane albo dla
45 ka¿dego ¿±dania lub przez specjalnie nazwane klucze w argumentach
46 ¿±dañ Masona, zaraz przed tym, jak Mason tworzy i wykonuje stos
47 ¿±danych komponentów.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/MasonX/*/*.pm
72 %{_mandir}/man3/*
This page took 0.056958 seconds and 3 git commands to generate.