]> git.pld-linux.org Git - packages/perl-MasonX-Interp-WithCallbacks.git/blob - perl-MasonX-Interp-WithCallbacks.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MasonX-Interp-WithCallbacks.git] / perl-MasonX-Interp-WithCallbacks.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    MasonX
6 %define         pnam    Interp-WithCallbacks
7 Summary:        MasonX::Interp::WithCallbacks - Mason callback support via Params::CallbackRequest
8 Summary(pl.UTF-8):      MasonX::Interp::WithCallbacks - obsługa callbacków Masona poprzez Params::CallbackRequest
9 Name:           perl-MasonX-Interp-WithCallbacks
10 Version:        1.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MasonX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7a4131bed5cc67df62dd27a7e8aa30d6
17 URL:            http://search.cpan.org/dist/MasonX-Interp-WithCallbacks/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Container >= 0.09
23 BuildRequires:  perl-HTML-Mason >= 1.23
24 BuildRequires:  perl-Params-CallbackRequest >= 1.11
25 BuildRequires:  perl-Test-Simple >= 0.17
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 MasonX::Interp::WithCallbacks subclasses HTML::Mason::Interp
32 in order to provide a Mason callback system built on
33 Params::CallbackRequest. Callbacks may be either code references
34 provided to the new() constructor, or methods defined in subclasses of
35 Params::Callback. Callbacks are triggered either for every request or
36 by specially named keys in the Mason request arguments, and all
37 callbacks are executed at the beginning of a request, just before
38 Mason creates and executes the request component stack.
39
40 %description -l pl.UTF-8
41 MasonX::Interp::WithCallbacks jest podklasą HTML::Mason::Interp
42 dostarczającą Masonowi system wywołań zwrotnych (callbacków) zbudowany
43 w oparciu o Params::CallbackRequest. Callbacki mogą być referencjami
44 do kodu przekazanymi do konstruktora new() lub metodami zdefiniowanymi
45 w podklasach Params::Callback. Wywołania zwrotne są wyzwalane albo dla
46 każdego żądania lub przez specjalnie nazwane klucze w argumentach
47 żądań Masona, zaraz przed tym, jak Mason tworzy i wykonuje stos
48 żądanych komponentów.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Build.PL \
55         installdirs=vendor \
56         destdir=$RPM_BUILD_ROOT
57 ./Build
58
59 %{?with_tests:./Build test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 ./Build install 
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %dir %{perl_vendorlib}/MasonX/Interp
73 %{perl_vendorlib}/MasonX/*/*.pm
74 %{_mandir}/man3/*
This page took 0.086836 seconds and 4 git commands to generate.