]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blob - perl-List-MoreUtils.spec
- up to 0.33
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    List
7 %define         pnam    MoreUtils
8 Summary:        List::MoreUtils - provide the stuff missing in List::Util
9 Summary(pl.UTF-8):      List::MoreUtils - dostarczenie elementów brakujących w List::Util
10 Name:           perl-List-MoreUtils
11 Version:        0.33
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8a33c84028cc2ff3e92c92434b326c0f
18 URL:            http://search.cpan.org/dist/List-MoreUtils/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 List::MoreUtils provides some trivial but commonly needed
25 functionality on lists which is not going to go into List::Util.
26
27 All of the below functions are implementable in one line of Perl code.
28 Using the functions from this module however should give slightly
29 better performance as everything is implemented in C. The pure-Perl
30 implementation of these functions only serves as a fallback in case
31 the C portions of this module couldn't be compiled on this machine.
32
33 %description -l pl.UTF-8
34 List::MoreUtils dostarcza prostych, ale często potrzebnych funkcji do
35 operacji na listach - elementy, które nie zostaną dołączone do
36 List::Util.
37
38 Wszystkie z funkcji są możliwe do implementowania w jednej linijce
39 kodu Perla. Używanie funkcji z tego modułu może jednak dać odrobinę
40 większą wydajność jako, że całość została napisana w C. Implementacja
41 napisana w Perlu służy w sytuacjach wyjątkowych w przypadkach, gdy
42 elementy modułu napisane w C nie mogą zostać skompilowane na maszynie.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %dir %{perl_vendorarch}/List
70 %{perl_vendorarch}/List/MoreUtils.pm
71 %dir %{perl_vendorarch}/auto/List/MoreUtils
72 %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.bs
73 %attr(755,root,root) %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.so
74 %{_mandir}/man3/List::MoreUtils.3pm*
This page took 0.273642 seconds and 4 git commands to generate.