]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blob - perl-List-MoreUtils.spec
- updated URL
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    List
6 %define         pnam    MoreUtils
7 Summary:        List::MoreUtils - provide the stuff missing in List::Util
8 Summary(pl.UTF-8):      List::MoreUtils - dostarczenie elementów brakujących w List::Util
9 Name:           perl-List-MoreUtils
10 Version:        0.430
11 Release:        1
12 # code before 0.417: same as perl 5.8.4 or later
13 License:        Apache v2.0 (code since 0.417), GPL v1+ or Artistic (older code)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  daccd6310021231b827dcc943ff1c6b7
17 URL:            https://metacpan.org/dist/List-MoreUtils
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.86
19 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
20 BuildRequires:  perl-devel >= 1:5.8.1
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-Exporter-Tiny >= 0.038
25 BuildRequires:  perl-List-MoreUtils-XS >= 0.430
26 BuildRequires:  perl-Storable
27 BuildRequires:  perl-Test-LeakTrace
28 BuildRequires:  perl-Test-Simple >= 0.96
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 List::MoreUtils provides some trivial but commonly needed
35 functionality on lists which is not going to go into List::Util.
36
37 All of the below functions are implementable in one line of Perl code.
38 Using the functions from this module however should give slightly
39 better performance as everything is implemented in C. The pure-Perl
40 implementation of these functions only serves as a fallback in case
41 the C portions of this module couldn't be compiled on this machine.
42
43 %description -l pl.UTF-8
44 List::MoreUtils dostarcza prostych, ale często potrzebnych funkcji do
45 operacji na listach - elementy, które nie zostaną dołączone do
46 List::Util.
47
48 Wszystkie z funkcji są możliwe do implementowania w jednej linijce
49 kodu Perla. Używanie funkcji z tego modułu może jednak dać odrobinę
50 większą wydajność jako, że całość została napisana w C. Implementacja
51 napisana w Perlu służy w sytuacjach wyjątkowych w przypadkach, gdy
52 elementy modułu napisane w C nie mogą zostać skompilowane na maszynie.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README.md
77 %dir %{perl_vendorlib}/List
78 %{perl_vendorlib}/List/MoreUtils.pm
79 %{perl_vendorlib}/List/MoreUtils
80 %{_mandir}/man3/List::MoreUtils*.3pm*
This page took 0.109085 seconds and 4 git commands to generate.