]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blob - perl-List-MoreUtils.spec
- more perl BRs, unified CPAN source URL
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    List
7 %define         pnam    MoreUtils
8 Summary:        List::MoreUtils - provide the stuff missing in List::Util
9 Summary(pl.UTF-8):      List::MoreUtils - dostarczenie elementów brakujących w List::Util
10 Name:           perl-List-MoreUtils
11 Version:        0.33
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8a33c84028cc2ff3e92c92434b326c0f
18 URL:            http://search.cpan.org/dist/List-MoreUtils/
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.52
20 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Test-Simple >= 0.82
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 List::MoreUtils provides some trivial but commonly needed
30 functionality on lists which is not going to go into List::Util.
31
32 All of the below functions are implementable in one line of Perl code.
33 Using the functions from this module however should give slightly
34 better performance as everything is implemented in C. The pure-Perl
35 implementation of these functions only serves as a fallback in case
36 the C portions of this module couldn't be compiled on this machine.
37
38 %description -l pl.UTF-8
39 List::MoreUtils dostarcza prostych, ale często potrzebnych funkcji do
40 operacji na listach - elementy, które nie zostaną dołączone do
41 List::Util.
42
43 Wszystkie z funkcji są możliwe do implementowania w jednej linijce
44 kodu Perla. Używanie funkcji z tego modułu może jednak dać odrobinę
45 większą wydajność jako, że całość została napisana w C. Implementacja
46 napisana w Perlu służy w sytuacjach wyjątkowych w przypadkach, gdy
47 elementy modułu napisane w C nie mogą zostać skompilowane na maszynie.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55
56 %{__make} \
57         CC="%{__cc}" \
58         OPTIMIZE="%{rpmcflags}"
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %dir %{perl_vendorarch}/List
75 %{perl_vendorarch}/List/MoreUtils.pm
76 %dir %{perl_vendorarch}/auto/List/MoreUtils
77 %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.bs
78 %attr(755,root,root) %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.so
79 %{_mandir}/man3/List::MoreUtils.3pm*
This page took 0.099632 seconds and 4 git commands to generate.