]> git.pld-linux.org Git - packages/perl-IO-Null.git/blob - perl-IO-Null.spec
- new, STBR
[packages/perl-IO-Null.git] / perl-IO-Null.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define pdir    IO
6 %define pnam    Null
7 Summary:        IO::Null -- class for null filehandles
8 #Summary(pl):   
9 Name:           perl-IO-Null
10 Version:        0.02
11 Release:        1
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 BuildRequires:  perl >= 5.6
16 BuildRequires:  rpm-perlprov >= 3.0.3-26
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is a class for null filehandles.
22
23 Calling a constructor of this class always succeeds, returning a new null
24 filehandle.
25
26 Writing to any object of this class is always a no-operation, and returns
27 true.
28
29 Reading from any object of this class is always no-operation, and returns
30 empty-string or empty-list, as appropriate.
31
32 # %description -l pl
33 # TODO
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 perl Makefile.PL
40 %{__make}
41
42 %{!?_without_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %{perl_sitelib}/%{pdir}/*.pm
55 %{_mandir}/man3/*
This page took 0.063895 seconds and 4 git commands to generate.