]> git.pld-linux.org Git - packages/perl-IO-Null.git/blob - perl-IO-Null.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IO-Null.git] / perl-IO-Null.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    IO
6 %define         pnam    Null
7 Summary:        IO::Null - class for null filehandles
8 Summary(pl.UTF-8):      IO::Null - klasa do pustych uchwytów plików
9 Name:           perl-IO-Null
10 Version:        1.01
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  54d6084398f8b4e7062660b9ccc835a8
17 URL:            http://search.cpan.org/dist/IO-Null/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a class for null filehandles.
25
26 Calling a constructor of this class always succeeds, returning a new
27 null filehandle.
28
29 Writing to any object of this class is always a no-operation, and
30 returns true.
31
32 Reading from any object of this class is always no-operation, and
33 returns empty-string or empty-list, as appropriate.
34
35 %description -l pl.UTF-8
36 To jest klasa pustych uchwytów plików. Wywołanie konstruktora tej
37 klasy zawsze kończy się sukcesem i zwracany jest pusty uchwyt pliku.
38 Zapis do dowolnego obiektu tej klasy jest pustą operacją, zwracającą
39 logiczną prawdę. Czytanie z dowolnego obiektu tej klasy jest pustą
40 operacją, zwracającą pusty ciąg lub pustą listę.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{perl_vendorlib}/%{pdir}/*.pm
64 %{_mandir}/man3/*
This page took 0.06415 seconds and 4 git commands to generate.