]> git.pld-linux.org Git - packages/perl-IO-Interface.git/blob - perl-IO-Interface.spec
- pl
[packages/perl-IO-Interface.git] / perl-IO-Interface.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Interface
8 Summary:        IO::Interface - Perl extension to access interface information
9 Summary(pl):    IO::Interface - rozszerzenie Perla do dostêpu do informacji o interfejsach
10 Name:           perl-IO-Interface
11 Version:        0.98
12 Release:        0.1
13 License:        GPL v2/Artistic (same as perl)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  91d5029a32302aa02414c9c8e3353cec
17 URL:            http://search.cpan.org/dist/IO-Interface/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IO::Interface adds methods to IO::Socket objects that allows them to
24 be used to retrieve and change information about the network
25 interfaces on your system.  In addition to the object-oriented access
26 methods, you can use a function-oriented style.
27
28 %description -l pl
29 IO::Interface dodaje do obiektów IO::Socket metody pozwalaj±ce na
30 u¿ywanie ich do pobierania i zmiany informacji o interfejsach
31 sieciowych w systemie. Oprócz metod zorientowanych obiektowo mo¿na
32 u¿ywaæ tak¿e wywo³añ zorientowanych na funkce.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make} \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/IO/Interface.pm
59 %dir %{perl_vendorarch}/auto/IO/Interface
60 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/*.so
61 %{perl_vendorarch}/auto/IO/Interface/*.bs
62 %{_mandir}/man3/*
This page took 0.041088 seconds and 3 git commands to generate.