]> git.pld-linux.org Git - packages/perl-HTML-Parser.git/blob - perl-HTML-Parser.spec
- updated to 3.71
[packages/perl-HTML-Parser.git] / perl-HTML-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    HTML
6 %define         pnam    Parser
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        HTML::Parser - parsing and extracting information from HTML documents
9 Summary(cs.UTF-8):      HTML::Parser - modul pro parsování HTML v Perlu
10 Summary(pl.UTF-8):      HTML::Parser - analiza i wyciąganie informacji z dokumentów HTML
11 Summary(ru.UTF-8):      HTML::Parser - набор модулей для "разбора" HTML-документов
12 Summary(uk.UTF-8):      HTML::Parser - набір модулів для розбору HTML-документів
13 Summary(zh_CN.UTF-8):   Perl 的 HTML 解析器模块。
14 Name:           perl-HTML-Parser
15 Version:        3.71
16 Release:        1
17 # same as perl
18 License:        GPL v1+ or Artistic
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
21 # Source0-md5:  9128a45893097dfa3bf03301b19c5efe
22 URL:            http://search.cpan.org/dist/HTML-Parser/
23 BuildRequires:  perl-HTML-Tagset >= 3
24 BuildRequires:  perl-devel >= 1:5.8.0
25 %{?with_tests:BuildRequires:    perl-libwww}
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildConflicts: perl-HTML-Stream = 1.45-3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # HTTP::Headers (perl-libwww) is not always required
31 %define         _noautoreq      perl(HTTP::Headers)
32
33 %description
34 Perl module HTML::Parser that allows to parse and extract information
35 from HTML documents.
36
37 %description -l cs.UTF-8
38 Balíček perl-HTML-Parser obsahuje modul pro Perl, který slouží k
39 parsování a extrahování informací z HTML dokumentu.
40
41 %description -l da.UTF-8
42 HTML::Parser modul til Perl for at tolka og extrahere information fra
43 HTML-dokument.
44
45 %description -l de.UTF-8
46 HTML::Parser modul für Perl zum Parsen und Extrahieren von
47 Informationen aus HTML-Dokumenten.
48
49 %description -l es.UTF-8
50 Módulo HTML::Parser para perl para analizar y extraer información a
51 partir de documentos HTML.
52
53 %description -l fr.UTF-8
54 Module HTML::Parser pour perl permettant d'analyser et d'extraire des
55 informations de documents HTML.
56
57 %description -l it.UTF-8
58 Il modulo HTML::Parser per perl, che consente di analizzare documenti
59 HTML e di estrarne informazioni.
60
61 %description -l ja.UTF-8
62 HTML ドキュメントから情報を解析、抽出するための Perl 用の HTML::Parser 。
63
64 %description -l ko.UTF-8
65 HTML::Parser 모줄은 펄이 HTML 문서들로 부터 정보를 파싱하고 가져오게끔 합니다.
66
67 %description -l pl.UTF-8
68 Moduł Perla HTML::Parser pozwalający na parsowanie i wyciąganie
69 informacji z dokumentu HTML.
70
71 %description -l pt_BR.UTF-8
72 Módulo Perl HTML::Parser - Uma coleção de módulos para examinar e
73 extrair informações de documentos HTML.
74
75 %description -l ru.UTF-8
76 HTML::Parser - набор модулей для "разбора" HTML-документов.
77
78 %description -l uk.UTF-8
79 HTML::Parser - набір модулів для розбору HTML-документів.
80
81 %description -l pt.UTF-8
82 O módulo HTML::Parser para o Perl analisar e extrair informações de
83 documentos HTML.
84
85 %description -l sv.UTF-8
86 HTML::Parser modul till perl för att tolka och extrahera information
87 från HTML-dokument.
88
89 %prep
90 %setup -q -n %{pdir}-%{pnam}-%{version}
91
92 %build
93 %{__perl} Makefile.PL \
94         INSTALLDIRS=vendor \
95         DEFINE="-DMARKED_SECTION -DUNICODE_ENTITIES" \
96         < /dev/null
97 %{__make} \
98         CC="%{__cc}" \
99         OPTIMIZE="%{rpmcflags}"
100
101 %{?with_tests:%{__make} test}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc Changes README TODO
115 %{perl_vendorarch}/HTML/Entities.pm
116 %{perl_vendorarch}/HTML/Filter.pm
117 %{perl_vendorarch}/HTML/HeadParser.pm
118 %{perl_vendorarch}/HTML/LinkExtor.pm
119 %{perl_vendorarch}/HTML/Parser.pm
120 %{perl_vendorarch}/HTML/PullParser.pm
121 %{perl_vendorarch}/HTML/TokeParser.pm
122 %dir %{perl_vendorarch}/auto/HTML/Parser
123 %{perl_vendorarch}/auto/HTML/Parser/Parser.bs
124 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/Parser/Parser.so
125 %{_mandir}/man3/HTML::Entities.3pm*
126 %{_mandir}/man3/HTML::Filter.3pm*
127 %{_mandir}/man3/HTML::HeadParser.3pm*
128 %{_mandir}/man3/HTML::LinkExtor.3pm*
129 %{_mandir}/man3/HTML::Parser.3pm*
130 %{_mandir}/man3/HTML::PullParser.3pm*
131 %{_mandir}/man3/HTML::TokeParser.3pm*
This page took 0.031432 seconds and 4 git commands to generate.