]> git.pld-linux.org Git - packages/perl-HTML-Parser.git/blob - perl-HTML-Parser.spec
perl 5.38.0 rebuild
[packages/perl-HTML-Parser.git] / perl-HTML-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         pdir    HTML
6 %define         pnam    Parser
7 Summary:        HTML::Parser - parsing and extracting information from HTML documents
8 Summary(cs.UTF-8):      HTML::Parser - modul pro parsování HTML v Perlu
9 Summary(pl.UTF-8):      HTML::Parser - analiza i wyciąganie informacji z dokumentów HTML
10 Summary(ru.UTF-8):      HTML::Parser - набор модулей для "разбора" HTML-документов
11 Summary(uk.UTF-8):      HTML::Parser - набір модулів для розбору HTML-документів
12 Summary(zh_CN.UTF-8):   Perl 的 HTML 解析器模块。
13 Name:           perl-HTML-Parser
14 Version:        3.81
15 Release:        2
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        https://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  b9f5dd3b14632f7a60541a2b61389c06
21 URL:            https://metacpan.org/release/HTML-Parser
22 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.52
23 BuildRequires:  perl-HTML-Tagset >= 3
24 BuildRequires:  perl-devel >= 1:5.8.0
25 %if %{with tests}
26 BuildRequires:  perl-Test-Simple
27 BuildRequires:  perl-URI
28 BuildRequires:  perl-libwww
29 %endif
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildRequires:  rpmbuild(macros) >= 1.745
32 BuildConflicts: perl-HTML-Stream = 1.45-3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # HTTP::Headers (perl-libwww) is not always required
36 %define         _noautoreq      perl(HTTP::Headers)
37
38 %description
39 Perl module HTML::Parser that allows to parse and extract information
40 from HTML documents.
41
42 %description -l cs.UTF-8
43 Balíček perl-HTML-Parser obsahuje modul pro Perl, který slouží k
44 parsování a extrahování informací z HTML dokumentu.
45
46 %description -l da.UTF-8
47 HTML::Parser modul til Perl for at tolka og extrahere information fra
48 HTML-dokument.
49
50 %description -l de.UTF-8
51 HTML::Parser modul für Perl zum Parsen und Extrahieren von
52 Informationen aus HTML-Dokumenten.
53
54 %description -l es.UTF-8
55 Módulo HTML::Parser para perl para analizar y extraer información a
56 partir de documentos HTML.
57
58 %description -l fr.UTF-8
59 Module HTML::Parser pour perl permettant d'analyser et d'extraire des
60 informations de documents HTML.
61
62 %description -l it.UTF-8
63 Il modulo HTML::Parser per perl, che consente di analizzare documenti
64 HTML e di estrarne informazioni.
65
66 %description -l ja.UTF-8
67 HTML ドキュメントから情報を解析、抽出するための Perl 用の HTML::Parser 。
68
69 %description -l ko.UTF-8
70 HTML::Parser 모줄은 펄이 HTML 문서들로 부터 정보를 파싱하고 가져오게끔 합니다.
71
72 %description -l pl.UTF-8
73 Moduł Perla HTML::Parser pozwalający na parsowanie i wyciąganie
74 informacji z dokumentu HTML.
75
76 %description -l pt_BR.UTF-8
77 Módulo Perl HTML::Parser - Uma coleção de módulos para examinar e
78 extrair informações de documentos HTML.
79
80 %description -l ru.UTF-8
81 HTML::Parser - набор модулей для "разбора" HTML-документов.
82
83 %description -l uk.UTF-8
84 HTML::Parser - набір модулів для розбору HTML-документів.
85
86 %description -l pt.UTF-8
87 O módulo HTML::Parser para o Perl analisar e extrair informações de
88 documentos HTML.
89
90 %description -l sv.UTF-8
91 HTML::Parser modul till perl för att tolka och extrahera information
92 från HTML-dokument.
93
94 %prep
95 %setup -q -n %{pdir}-%{pnam}-%{version}
96
97 %build
98 %{__perl} Makefile.PL \
99         INSTALLDIRS=vendor \
100         DEFINE="-DMARKED_SECTION -DUNICODE_ENTITIES" \
101         < /dev/null
102 %{__make} \
103         CC="%{__cc}" \
104         OPTIMIZE="%{rpmcflags}"
105
106 %{?with_tests:%{__make} test}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc Changes TODO
120 %{perl_vendorarch}/HTML/Entities.pm
121 %{perl_vendorarch}/HTML/Filter.pm
122 %{perl_vendorarch}/HTML/HeadParser.pm
123 %{perl_vendorarch}/HTML/LinkExtor.pm
124 %{perl_vendorarch}/HTML/Parser.pm
125 %{perl_vendorarch}/HTML/PullParser.pm
126 %{perl_vendorarch}/HTML/TokeParser.pm
127 %dir %{perl_vendorarch}/auto/HTML/Parser
128 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/Parser/Parser.so
129 %{_mandir}/man3/HTML::Entities.3pm*
130 %{_mandir}/man3/HTML::Filter.3pm*
131 %{_mandir}/man3/HTML::HeadParser.3pm*
132 %{_mandir}/man3/HTML::LinkExtor.3pm*
133 %{_mandir}/man3/HTML::Parser.3pm*
134 %{_mandir}/man3/HTML::PullParser.3pm*
135 %{_mandir}/man3/HTML::TokeParser.3pm*
This page took 0.09595 seconds and 4 git commands to generate.