]> git.pld-linux.org Git - packages/perl-HTML-Parser.git/blob - perl-HTML-Parser.spec
- rel 2
[packages/perl-HTML-Parser.git] / perl-HTML-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    Parser
8 Summary:        HTML::Parser - parsing and extracting information from HTML documents
9 Summary(cs.UTF-8):      HTML::Parser - modul pro parsování HTML v Perlu
10 Summary(pl.UTF-8):      HTML::Parser - analiza i wyciąganie informacji z dokumentów HTML
11 Summary(ru.UTF-8):      HTML::Parser - набор модулей для "разбора" HTML-документов
12 Summary(uk.UTF-8):      HTML::Parser - набір модулів для розбору HTML-документів
13 Summary(zh_CN.UTF-8):   Perl 的 HTML 解析器模块。
14 Name:           perl-HTML-Parser
15 Version:        3.56
16 Release:        2
17 # same as perl
18 License:        GPL v1+ or Artistic
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 # Source0-md5:  bddc432e5ed9df4d4153a62234f04fc2
22 URL:            http://search.cpan.org/dist/HTML-Parser/
23 BuildRequires:  perl-HTML-Tagset >= 3
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildConflicts: perl-HTML-Stream = 1.45-3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # HTTP::Headers (perl-libwww) is not always required
30 %define         _noautoreq      'perl(HTTP::Headers)'
31
32 %description
33 Perl module HTML::Parser that allows to parse and extract information
34 from HTML documents.
35
36 %description -l cs.UTF-8
37 Balíček perl-HTML-Parser obsahuje modul pro Perl, který slouží k
38 parsování a extrahování informací z HTML dokumentu.
39
40 %description -l da.UTF-8
41 HTML::Parser modul til Perl for at tolka og extrahere information fra
42 HTML-dokument.
43
44 %description -l de.UTF-8
45 HTML::Parser modul für Perl zum Parsen und Extrahieren von
46 Informationen aus HTML-Dokumenten.
47
48 %description -l es.UTF-8
49 Módulo HTML::Parser para perl para analizar y extraer información a
50 partir de documentos HTML.
51
52 %description -l fr.UTF-8
53 Module HTML::Parser pour perl permettant d'analyser et d'extraire des
54 informations de documents HTML.
55
56 %description -l it.UTF-8
57 Il modulo HTML::Parser per perl, che consente di analizzare documenti
58 HTML e di estrarne informazioni.
59
60 %description -l ja.UTF-8
61 HTML ドキュメントから情報を解析、抽出するための Perl 用の HTML::Parser
62
63
64 %description -l ko.UTF-8
65 HTML::Parser 모줄은 펄이 HTML 문서들로 부터 정보를 파싱하고 가져오게끔
66 합니다.
67
68 %description -l pl.UTF-8
69 Moduł Perla HTML::Parser pozwalający na parsowanie i wyciąganie
70 informacji z dokumentu HTML.
71
72 %description -l pt_BR.UTF-8
73 Módulo Perl HTML::Parser - Uma coleção de módulos para examinar e
74 extrair informações de documentos HTML.
75
76 %description -l ru.UTF-8
77 HTML::Parser - набор модулей для "разбора" HTML-документов.
78
79 %description -l uk.UTF-8
80 HTML::Parser - набір модулів для розбору HTML-документів.
81
82 %description -l pt.UTF-8
83 O módulo HTML::Parser para o Perl analisar e extrair informações de
84 documentos HTML.
85
86 %description -l sv.UTF-8
87 HTML::Parser modul till perl för att tolka och extrahera information
88 från HTML-dokument.
89
90 %prep
91 %setup -q -n %{pdir}-%{pnam}-%{version}
92
93 %build
94 %{__perl} Makefile.PL \
95         INSTALLDIRS=vendor \
96         DEFINE="-DMARKED_SECTION -DUNICODE_ENTITIES" \
97         < /dev/null
98 %{__make} \
99         CC="%{__cc}" \
100         OPTIMIZE="%{rpmcflags}"
101
102 %{?with_tests:%{__make} test}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc Changes README TODO
116 %dir %{perl_vendorarch}/HTML
117 %{perl_vendorarch}/HTML/*.pm
118 %dir %{perl_vendorarch}/auto/HTML
119 %dir %{perl_vendorarch}/auto/HTML/Parser
120 %{perl_vendorarch}/auto/HTML/Parser/Parser.bs
121 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/Parser/Parser.so
122 %{_mandir}/man3/*
This page took 0.033701 seconds and 4 git commands to generate.