]> git.pld-linux.org Git - packages/perl-HTML-Parser.git/blob - perl-HTML-Parser.spec
- license fixes and unification
[packages/perl-HTML-Parser.git] / perl-HTML-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    Parser
8 Summary:        HTML::Parser - parsing and extracting information from HTML documents
9 Summary(cs):    HTML::Parser - modul pro parsování HTML v Perlu
10 Summary(pl):    HTML::Parser - analiza i wyci±ganie informacji z dokumentów HTML
11 Summary(ru):    HTML::Parser - ÎÁÂÏÒ ÍÏÄÕÌÅÊ ÄÌÑ "ÒÁÚÂÏÒÁ" HTML-ÄÏËÕÍÅÎÔÏ×
12 Summary(uk):    HTML::Parser - ÎÁ¦ҠÍÏÄÕ̦נÄÌÑ ÒÏÚÂÏÒÕ HTML-ÄÏËÕÍÅÎÔ¦×
13 Summary(zh_CN): Perl µÄ HTML ½âÎöÆ÷Ä£¿é¡£
14 Name:           perl-HTML-Parser
15 Version:        3.36
16 Release:        1
17 # same as perl
18 License:        GPL v1+ or Artistic
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 # Source0-md5:  0f3aae0994e04cc5afd020a896b6c595
22 BuildRequires:  perl-HTML-Tagset >= 3
23 BuildRequires:  perl-devel >= 5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildConflicts: perl-HTML-Stream = 1.45-3
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # HTTP::Headers (perl-libwww) is not always required
29 %define         _noautoreq      'perl(HTTP::Headers)'
30
31 %description
32 Perl module HTML::Parser that allows to parse and extract information
33 from HTML documents.
34
35 %description -l cs
36 Balíèek perl-HTML-Parser obsahuje modul pro Perl, který slou¾í k
37 parsování a extrahování informací z HTML dokumentu.
38
39 %description -l da
40 HTML::Parser modul til Perl for at tolka og extrahere information fra
41 HTML-dokument.
42
43 %description -l de
44 HTML::Parser modul für Perl zum Parsen und Extrahieren von
45 Informationen aus HTML-Dokumenten.
46
47 %description -l es
48 Módulo HTML::Parser para perl para analizar y extraer información a
49 partir de documentos HTML.
50
51 %description -l fr
52 Module HTML::Parser pour perl permettant d'analyser et d'extraire des
53 informations de documents HTML.
54
55 %description -l it
56 Il modulo HTML::Parser per perl, che consente di analizzare documenti
57 HTML e di estrarne informazioni.
58
59 %description -l ja
60 HTML ¥É¥­¥å¥á¥ó¥È¤«¤é¾ðÊó¤ò²òÀÏ¡¢Ãê½Ð¤¹¤ë¤¿¤á¤Î Perl ÍѤΠHTML::Parser
61 ¡£
62
63 %description -l ko
64 HTML::Parser ¸ðÁÙÀº ÆÞÀÌ HTML ¹®¼­µé·Î ºÎÅÍ Á¤º¸¸¦ ÆĽÌÇÏ°í °¡Á®¿À°Ô²û
65 ÇÕ´Ï´Ù.
66
67 %description -l pl
68 Modu³ Perla HTML::Parser pozwalaj±cy na parsowanie i wyciaganie
69 informacji z dokumentu HTML.
70
71 %description -l pt_BR
72 Módulo Perl HTML::Parser - Uma coleção de módulos para examinar e
73 extrair informações de documentos HTML.
74
75 %description -l ru
76 HTML::Parser - ÎÁÂÏÒ ÍÏÄÕÌÅÊ ÄÌÑ "ÒÁÚÂÏÒÁ" HTML-ÄÏËÕÍÅÎÔÏ×.
77
78 %description -l uk
79 HTML::Parser - ÎÁ¦ҠÍÏÄÕ̦נÄÌÑ ÒÏÚÂÏÒÕ HTML-ÄÏËÕÍÅÎÔ¦×.
80
81 %description -l pt
82 O módulo HTML::Parser para o Perl analisar e extrair informações de
83 documentos HTML.
84
85 %description -l sv
86 HTML::Parser modul till perl för att tolka och extrahera information
87 från HTML-dokument.
88
89 %prep
90 %setup -q -n %{pdir}-%{pnam}-%{version}
91
92 %build
93 %{__perl} Makefile.PL \
94         INSTALLDIRS=vendor \
95         DEFINE="-DMARKED_SECTION -DUNICODE_ENTITIES" \
96         < /dev/null
97 %{__make} \
98         OPTIMIZE="%{rpmcflags}"
99
100 %{?with_tests:%{__make} test}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc Changes README TODO
114 %dir %{perl_vendorarch}/HTML
115 %{perl_vendorarch}/HTML/*.pm
116 %dir %{perl_vendorarch}/auto/HTML
117 %dir %{perl_vendorarch}/auto/HTML/Parser
118 %{perl_vendorarch}/auto/HTML/Parser/Parser.bs
119 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/Parser/Parser.so
120 %{_mandir}/man3/*
This page took 0.065058 seconds and 4 git commands to generate.