]> git.pld-linux.org Git - packages/perl-Geo-IP.git/blob - perl-Geo-IP.spec
- tabs in preamble
[packages/perl-Geo-IP.git] / perl-Geo-IP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" 
4                         # (requires working DNS - but may fail anyway, because of some NXDOMAIN)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Geo
8 %define         pnam    IP
9 Summary:        Geo::IP - look up country by IP Address
10 Summary(pl.UTF-8):      Geo::IP - odszukanie kraju po adresie IP
11 Name:           perl-Geo-IP
12 Version:        1.27
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Geo/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  10ec3c74808ffbca871eca4db77209bd
19 URL:            http://search.cpan.org/dist/Geo-IP/
20 BuildRequires:  GeoIP-devel
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module uses a file based database. This database simply contains
27 IP blocks as keys, and countries as values. This database should be
28 more complete and accurate than reverse DNS lookups.
29
30 This module can be used to automatically select the geographically
31 closest mirror, to analyze your web server logs to determine the
32 countries of your visitors, for credit card fraud detection, and for
33 software export controls.
34
35 %description -l pl.UTF-8
36 Ten moduł używa bazy danych w postaci pliku. W bazie tej adresy IP są
37 kluczami, a państwa wartościami. Powinna ona być dokładniejsza niż
38 sprawdzanie odwrotnego DNS.
39
40 Ta biblioteka może być używana do automatycznego wyboru najbliższego
41 geograficznie mirrora, analizy logów serwera WWW w celu określenia
42 kraju, z którego pochodzą odwiedzający, do wykrywania oszustw
43 dotyczących kart kredytowych oraz kontroli eksportu oprogramowania.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make} \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %dir %{perl_vendorarch}/Geo
70 %{perl_vendorarch}/Geo/*.pm
71 %dir %{perl_vendorarch}/Geo/IP
72 %{perl_vendorarch}/Geo/IP/*.pm
73 %dir %{perl_vendorarch}/auto/Geo
74 %dir %{perl_vendorarch}/auto/Geo/IP
75 %{perl_vendorarch}/auto/Geo/IP/IP.bs
76 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/IP/IP.so
77 %{_mandir}/man3/*
This page took 0.028754 seconds and 4 git commands to generate.