]> git.pld-linux.org Git - packages/perl-Geo-IP.git/blob - perl-Geo-IP.spec
perl 5.38.0 rebuild
[packages/perl-Geo-IP.git] / perl-Geo-IP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" 
4                         # (requires working DNS - but may fail anyway, because of some NXDOMAIN)
5 #
6 %define         pdir    Geo
7 %define         pnam    IP
8 Summary:        Geo::IP - look up country by IP Address
9 Summary(pl.UTF-8):      Geo::IP - odszukanie kraju po adresie IP
10 Name:           perl-Geo-IP
11 Version:        1.51
12 Release:        7
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Geo/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  da22ae4cc1362f5460d6b0972e5e330b
18 URL:            http://search.cpan.org/dist/Geo-IP/
19 BuildRequires:  GeoIP-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module uses a file based database. This database simply contains
26 IP blocks as keys, and countries as values. This database should be
27 more complete and accurate than reverse DNS lookups.
28
29 This module can be used to automatically select the geographically
30 closest mirror, to analyze your web server logs to determine the
31 countries of your visitors, for credit card fraud detection, and for
32 software export controls.
33
34 %description -l pl.UTF-8
35 Ten moduł używa bazy danych w postaci pliku. W bazie tej adresy IP są
36 kluczami, a państwa wartościami. Powinna ona być dokładniejsza niż
37 sprawdzanie odwrotnego DNS.
38
39 Ta biblioteka może być używana do automatycznego wyboru najbliższego
40 geograficznie mirrora, analizy logów serwera WWW w celu określenia
41 kraju, z którego pochodzą odwiedzający, do wykrywania oszustw
42 dotyczących kart kredytowych oraz kontroli eksportu oprogramowania.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/IP/Record.pod
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %dir %{perl_vendorarch}/Geo
71 %{perl_vendorarch}/Geo/*.pm
72 %dir %{perl_vendorarch}/Geo/IP
73 %{perl_vendorarch}/Geo/IP/*.pm
74 %dir %{perl_vendorarch}/auto/Geo
75 %dir %{perl_vendorarch}/auto/Geo/IP
76 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/IP/IP.so
77 %{_mandir}/man3/Geo::*.3pm*
This page took 0.100258 seconds and 4 git commands to generate.