]> git.pld-linux.org Git - packages/perl-Geo-IP.git/blob - perl-Geo-IP.spec
- initial import
[packages/perl-Geo-IP.git] / perl-Geo-IP.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 # ToDo:
6 # - make the package build even with tests
7 # - summary / descriptions
8 %include        /usr/lib/rpm/macros.perl
9 %define pdir    Geo
10 %define pnam    IP
11 Summary:        -
12 Summary(pl):    -
13 Name:           perl-%{pdir}-%{pnam}
14 Version:        1.15
15 Release:        0.1
16 License:        GPL     
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
19 BuildRequires:  perl-devel >= 5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25
26 %description -l pl
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 # Don't use pipes here: they generally don't work. Apply a patch.
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor \
35         LIBS="-L/usr/lib" \
36         INC='-I/usr/include'
37 %{__make}
38 # if module isn't noarch, use:
39 # %{__make} OPTIMIZE="%{rpmcflags}"
40
41 %{!?_without_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 # use macros:
56 #%%{perl_vendorlib}/...
57 %{perl_vendorarch}/*
58 %{_mandir}/man3/*
This page took 0.401378 seconds and 3 git commands to generate.