]> git.pld-linux.org Git - packages/perl-File-Type.git/blob - perl-File-Type.spec
- new
[packages/perl-File-Type.git] / perl-File-Type.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    File
7 %define pnam    Type
8 Summary:        File::Type - determine file type using magic
9 #Summary(pl):   
10 Name:           perl-File-Type
11 Version:        0.22
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4be3b0b7000b325c60351fcc8a04815d
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 File::Type uses magic numbers (typically at the start of a file) to
25 determine the MIME type of that file.
26
27 File::Type can use either a filename, or file contents, to determine
28 the type of a file.
29
30 # %description -l pl
31 # TODO
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes
55 %{perl_vendorlib}/File/*.pm
56 %{perl_vendorlib}/File/Type
57 %{_mandir}/man3/*
This page took 0.099462 seconds and 3 git commands to generate.