]> git.pld-linux.org Git - packages/perl-FCGI.git/blob - perl-FCGI.spec
- release 6
[packages/perl-FCGI.git] / perl-FCGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    FCGI
7 Summary:        FCGI - Fast CGI module
8 Summary(pl.UTF-8):      FCGI - szybki moduł CGI
9 Name:           perl-FCGI
10 Version:        0.67
11 Release:        6
12 License:        BSD-like
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/FCGI-%{version}.tar.gz
15 # Source0-md5:  2e9b5bd1f74290fd9788555e8108a3d2
16 Source1:        %{name}-acinclude.m4
17 URL:            http://www.fastcgi.com/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a FastCGI module for perl. It's based on the FCGI module that
26 comes with Open Market's FastCGI Developer's Kit, but does not require
27 you to recompile perl.
28
29 %description -l pl.UTF-8
30 To jest moduł FastCGI. Jest bazowany na module FCGI dostarczanym z
31 FastCGI Developer's Kit, ale nie wymaga rekompilacji Perla.
32
33 %prep
34 %setup -q -n %{pdir}-%{version}
35 cp -f %{SOURCE1} acinclude.m4
36
37 %build
38 %{__aclocal}
39 %{__autoconf}
40 %configure
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install *.fpl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
59 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{pdir}/.packlist
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Change* LICENSE.TERMS README
67 %{perl_vendorarch}/FCGI.pm
68 %dir %{perl_vendorarch}/auto/FCGI
69 %{perl_vendorarch}/auto/FCGI/FCGI.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/FCGI/FCGI.so
71 %{_mandir}/man3/*
72 %dir %{_examplesdir}/%{name}-%{version}
73 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.fpl
This page took 0.024838 seconds and 3 git commands to generate.