]> git.pld-linux.org Git - packages/perl-Exception-Class.git/blob - perl-Exception-Class.spec
- mass commit: cosmetics (removed trailing white spaces)
[packages/perl-Exception-Class.git] / perl-Exception-Class.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Exception
7 %define pnam    Class
8 Summary:        Exception::Class - declare real exception classes in Perl
9 Summary(pl):    Exception::Class - deklarowanie prawdziwych klas wyj±tków w Perlu
10 Name:           perl-Exception-Class
11 Version:        1.12
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  797eec381e2052b644f102d5b38fe037
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-devel >= 5.005
19 %if %{!?_without_tests:1}0
20 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
21 BuildRequires:  perl-Devel-StackTrace >= 1.03
22 BuildRequires:  perl(Test::More) >= 0.46
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Exception::Class allows you to declare exceptions in your modules
29 in a manner similar to how exceptions are declared in Java.
30
31 %description -l pl
32 Exception::Class pozwala na deklarowanie w modu³ach wyj±tków
33 w sposób podobny do stosowanego w Javie.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{!?_without_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README Changes LICENSE
56 %{perl_vendorlib}/Exception
57 %{_mandir}/man3/*
This page took 0.07282 seconds and 3 git commands to generate.