]> git.pld-linux.org Git - packages/perl-Exception-Class.git/blob - perl-Exception-Class.spec
- updated URL and macros
[packages/perl-Exception-Class.git] / perl-Exception-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Exception
6 %define         pnam    Class
7 Summary:        Exception::Class - declare real exception classes in Perl
8 Summary(pl.UTF-8):      Exception::Class - deklarowanie prawdziwych klas wyjątków w Perlu
9 Name:           perl-Exception-Class
10 Version:        1.45
11 Release:        1
12 License:        Artistic 2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Exception/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  1e564d20b374a99fdf660ba3f36b0098
16 URL:            https://metacpan.org/dist/Exception-Class
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
23 BuildRequires:  perl-Devel-StackTrace >= 2.00
24 BuildRequires:  perl-Test-Simple >= 0.96
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreq      perl($isa)
30
31 %description
32 Exception::Class allows you to declare exceptions in your modules
33 in a manner similar to how exceptions are declared in Java.
34
35 %description -l pl.UTF-8
36 Exception::Class pozwala na deklarowanie w modułach wyjątków
37 w sposób podobny do stosowanego w Javie.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes LICENSE
61 %dir %{perl_vendorlib}/Exception
62 %{perl_vendorlib}/Exception/Class.pm
63 %{perl_vendorlib}/Exception/Class
64 %{_mandir}/man3/Exception::Class*.3pm*
This page took 0.130051 seconds and 4 git commands to generate.