]> git.pld-linux.org Git - packages/perl-Exception-Class.git/blob - perl-Exception-Class.spec
- use the __perl macro
[packages/perl-Exception-Class.git] / perl-Exception-Class.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Exception
7 %define pnam    Class
8 Summary:        Exception::Class - Declare real exception classes in Perl
9 Summary(pl):    Exception::Class - Zadeklaruj prawdziwe klasy wyj±tków w Perlu
10 Name:           perl-Exception-Class
11 Version:        1.11
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  rpm-perlprov >= 3.0.3-16
17 BuildRequires:  perl >= 5.005
18 %if %{!?_without_tests:1}0
19 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
20 BuildRequires:  perl-Devel-StackTrace >= 1.03
21 BuildRequires:  perl(Test::More) >= 0.46
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Exception::Class allows you to declare exceptions in your modules
28 in a manner similar to how exceptions are declared in Java.
29
30 %description -l pl
31 Exception::Class pozwala na deklarowanie w modu³ach wyj±tków
32 w sposób podobny do stosowanego w Javie.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL
39 %{__make}
40
41 %{!?_without_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README Changes LICENSE
54 %{perl_sitelib}/Exception
55 %{_mandir}/man3/*
This page took 0.140284 seconds and 3 git commands to generate.