]> git.pld-linux.org Git - packages/perl-Email-Abstract.git/blob - perl-Email-Abstract.spec
- pl desc
[packages/perl-Email-Abstract.git] / perl-Email-Abstract.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Email
7 %define pnam    Abstract
8 Summary:        Unified interface to mail representations
9 Summary(pl):    Zunifikiowany interfejs do reprezentacji listów
10 Name:           perl-%{pdir}-%{pnam}
11 Version:        1.0
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic     
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ed5f792c40511b23356cefeea22b0703
18 BuildRequires:  perl-Email-Simple
19 BuildRequires:  perl-Module-Pluggable
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Email::Abstract provides module writers with the ability to write
27 representation-independent mail handling code. For instance, in the
28 cases of Mail::Thread or Mail::ListDetector, a key part of the code
29 involves reading the headers from a mail object. Where previously one
30 would either have to specify the mail class required, or to build a
31 new object from scratch, Email::Abstract can be used to perform
32 certain simple operations on an object regardless of its underlying
33 representation.
34
35 Email::Abstract currently supports Mail::Internet, MIME::Entity,
36 Mail::Message, Email::Simple and Email::MIME. Other representations
37 are encouraged to create their own Email::Abstract::* class by copying
38 Email::Abstract::EmailSimple. All modules installed under the
39 Email::Abstract hierarchy will be automatically picked up and used.
40
41 %description -l pl
42 Email::Abstract dostarcza pisz±cym modu³y mo¿liwo¶æ pisania kodu
43 obs³uguj±cego listy elektroniczne niezale¿nie od reprezentacji. Na
44 przyk³ad w przypadku Mail::Thread lub Mail::ListDetector znacz±ca
45 czê¶æ kodu dotyczy czytania nag³ówków z obiektu listu. Tam, gdzie
46 poprzednio trzeba by³o podaæ wymagan± nazwê klasy lub zbudowaæ
47 nowy obiekt od pocz±tku, mo¿na u¿yæ Email::Abstract do wykonania
48 pewnych prostych operacji na obiekcie niezale¿nie od jego
49 reprezentacji.
50
51 Email::Abstract aktualnie obs³uguje Mail::Internet, MIME::Entity,
52 Mail::Message, Email::Simple oraz Email::MIME. Dla innych
53 reprezentacji zaleca siê stworzyæ w³asn± klasê Email::Abstract::*
54 poprzez skopiowanie Email::Abstract::EmailSimple. Wszystkie modu³y
55 zainstalowane w hierarchii Email::Abstract s± automatycznie u¿ywane.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorlib}/Email/Abstract.pm
81 %{perl_vendorlib}/Email/Abstract
82 %{_mandir}/man3/*
This page took 0.047383 seconds and 4 git commands to generate.