]> git.pld-linux.org Git - packages/perl-Devel-Size.git/blob - perl-Devel-Size.spec
- rebuild with perl 5.18.0
[packages/perl-Devel-Size.git] / perl-Devel-Size.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Devel
7 %define         pnam    Size
8 Summary:        Devel::Size - finding the memory usage of Perl variables
9 Summary(pl.UTF-8):      Devel::Size - określanie zużycia pamięci przez zmienne Perla
10 Name:           perl-Devel-Size
11 Version:        0.77
12 Release:        2
13 # same as perl itself (as stated in COPYRIGHT section of pod)
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3ed95f459e9fab52d6d2b3aebf9343fd
18 URL:            http://search.cpan.org/dist/Devel-Size/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module figures out the real sizes of Perl variables in bytes.
25 Call functions with a reference to the variable you want the size
26 of.  If the variable is a plain scalar it returns the size of
27 the scalar.  If the variable is a hash or an array, use a reference
28 when calling.
29
30 %description -l pl.UTF-8
31 Ten moduł oblicza prawdziwe rozmiary zmiennych perlowych w bajtach.
32 Wystarczy wywołać funkcję z referencją do zmiennej, której rozmiar
33 chce się poznać. Jeśli zmienna jest skalarem, zwraca rozmiar skalara.
34 Jeśli zmienna jest haszem lub tablicą, należy użyć referencji przy
35 wywołaniu.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES
61 %{perl_vendorarch}/Devel/Size.pm
62 %dir %{perl_vendorarch}/auto/Devel/Size
63 %{perl_vendorarch}/auto/Devel/Size/Size.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/Size/Size.so
65 %{_mandir}/man3/*
This page took 0.066729 seconds and 3 git commands to generate.