]> git.pld-linux.org Git - packages/perl-Devel-Size.git/blob - perl-Devel-Size.spec
perl 5.38.0 rebuild
[packages/perl-Devel-Size.git] / perl-Devel-Size.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    Size
7 Summary:        Devel::Size - finding the memory usage of Perl variables
8 Summary(pl.UTF-8):      Devel::Size - określanie zużycia pamięci przez zmienne Perla
9 Name:           perl-Devel-Size
10 Version:        0.83
11 Release:        4
12 # same as perl itself (as stated in COPYRIGHT section of pod)
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0b5335d69402c75d5ab9978027ae2f66
17 URL:            https://metacpan.org/release/Devel-Size
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module figures out the real sizes of Perl variables in bytes.
25 Call functions with a reference to the variable you want the size
26 of.  If the variable is a plain scalar it returns the size of
27 the scalar.  If the variable is a hash or an array, use a reference
28 when calling.
29
30 %description -l pl.UTF-8
31 Ten moduł oblicza prawdziwe rozmiary zmiennych perlowych w bajtach.
32 Wystarczy wywołać funkcję z referencją do zmiennej, której rozmiar
33 chce się poznać. Jeśli zmienna jest skalarem, zwraca rozmiar skalara.
34 Jeśli zmienna jest haszem lub tablicą, należy użyć referencji przy
35 wywołaniu.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES
61 %{perl_vendorarch}/Devel/Size.pm
62 %dir %{perl_vendorarch}/auto/Devel/Size
63 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/Size/Size.so
64 %{_mandir}/man3/Devel::Size.3pm*
This page took 0.298675 seconds and 4 git commands to generate.