]> git.pld-linux.org Git - packages/perl-DateTime-TimeZone.git/blob - perl-DateTime-TimeZone.spec
- updated to 0.3801
[packages/perl-DateTime-TimeZone.git] / perl-DateTime-TimeZone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DateTime
7 %define         pnam    TimeZone
8 Summary:        DateTime::TimeZone - time zone object base class and factory
9 Summary(pl):    DateTime::TimeZone - podstawowe klasy obiektowe do obs³ugi stref czasowych
10 Name:           perl-DateTime-TimeZone
11 Version:        0.3801
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  045acc5dbb3b33ec1feb3a9aed28d55d
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 # most test skipped without DateTime >= 0.1501
24 BuildRequires:  perl-DateTime >= 0.15_01
25 BuildRequires:  perl-Params-Validate >= 0.72
26 %endif
27 Requires:       perl-Class-Singleton >= 1.03
28 Requires:       perl-Params-Validate >= 0.72
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This class is the base class for all time zone objects. A time
34 zone is represented internally as a set of observances, each
35 of which describes the offset from GMT for a given time period.
36 Note that without the "DateTime.pm" module, this module does not
37 do much. It's primary interface is through a "DateTime" object,
38 and most users will not need to directly use "DateTime::TimeZone"
39 methods.
40
41 %description -l pl
42 Jest to klasa bazowa dla klas wszystkich obiektów stref czasowych.
43 Strefa czasowa jest reprezentowana przez zbiór regu³, z których ka¿da
44 okre¶la przesuniêcie o zadany okres czasu w stosunku do czasu
45 uniwersalnego (GMT). Nale¿y zwróciæ uwagê, ¿e bez modu³u "DateTime.pm"
46 modu³ ten nie jest w stanie wiele zdzia³aæ. Jego podstawowym
47 interfejsem jest modu³ "DateTime" i w wiêkszo¶ci przypadków nie ma
48 potrzeby bezpo¶redniego korzystania z metod "DateTime::TimeZone".
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Build.PL \
55         installdirs=vendor \
56         destdir=$RPM_BUILD_ROOT
57 ./Build
58
59 %{?with_tests:./Build test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/DateTime/TimeZone*pm
72 %dir %{perl_vendorlib}/DateTime/TimeZone
73 %{perl_vendorlib}/DateTime/TimeZone/*.pm
74 %dir %{perl_vendorlib}/DateTime/TimeZone/Africa
75 %{perl_vendorlib}/DateTime/TimeZone/Africa/*.pm
76 %dir %{perl_vendorlib}/DateTime/TimeZone/Indian
77 %{perl_vendorlib}/DateTime/TimeZone/Indian/*.pm
78 %dir %{perl_vendorlib}/DateTime/TimeZone/Pacific
79 %{perl_vendorlib}/DateTime/TimeZone/Pacific/*.pm
80 %dir %{perl_vendorlib}/DateTime/TimeZone/Europe
81 %{perl_vendorlib}/DateTime/TimeZone/Europe/*.pm
82 %dir %{perl_vendorlib}/DateTime/TimeZone/Asia
83 %{perl_vendorlib}/DateTime/TimeZone/Asia/*.pm
84 %dir %{perl_vendorlib}/DateTime/TimeZone/America
85 %{perl_vendorlib}/DateTime/TimeZone/America/*.pm
86 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Argentina
87 %{perl_vendorlib}/DateTime/TimeZone/America/Argentina/*.pm
88 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Indiana
89 %{perl_vendorlib}/DateTime/TimeZone/America/Indiana/*.pm
90 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Kentucky
91 %{perl_vendorlib}/DateTime/TimeZone/America/Kentucky/*.pm
92 %dir %{perl_vendorlib}/DateTime/TimeZone/America/North_Dakota
93 %{perl_vendorlib}/DateTime/TimeZone/America/North_Dakota/*.pm
94 %dir %{perl_vendorlib}/DateTime/TimeZone/Australia
95 %{perl_vendorlib}/DateTime/TimeZone/Australia/*.pm
96 %dir %{perl_vendorlib}/DateTime/TimeZone/Atlantic
97 %{perl_vendorlib}/DateTime/TimeZone/Atlantic/*.pm
98 %dir %{perl_vendorlib}/DateTime/TimeZone/Antarctica
99 %{perl_vendorlib}/DateTime/TimeZone/Antarctica/*.pm
100 %{_mandir}/man3/*
This page took 0.417278 seconds and 4 git commands to generate.