]> git.pld-linux.org Git - packages/perl-DateTime-TimeZone.git/blob - perl-DateTime-TimeZone.spec
- updated to 2.47
[packages/perl-DateTime-TimeZone.git] / perl-DateTime-TimeZone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    DateTime
6 %define         pnam    TimeZone
7 Summary:        DateTime::TimeZone - time zone object base class and factory
8 Summary(pl.UTF-8):      DateTime::TimeZone - podstawowe klasy obiektowe do obsługi stref czasowych
9 Name:           perl-DateTime-TimeZone
10 Version:        2.47
11 Release:        1
12 Epoch:          3
13 # same as perl 5
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3ba0c9f5aeae945d2111f28333bd1a3d
18 URL:            https://metacpan.org/release/DateTime-TimeZone
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
20 BuildRequires:  perl(Pod::Man) >= 1.14
21 BuildRequires:  perl-devel >= 1:5.8.4
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 %if %{with tests}
25 BuildRequires:  perl(Cwd) >= 3
26 BuildRequires:  perl-Class-Singleton >= 1.03
27 # most tests skipped without DateTime >= 0.1501
28 BuildRequires:  perl-DateTime >= 0.15_01
29 BuildRequires:  perl-Module-Runtime
30 BuildRequires:  perl-Params-ValidationCompiler >= 0.13
31 BuildRequires:  perl-Scalar-List-Utils >= 1.33
32 BuildRequires:  perl-Specio
33 BuildRequires:  perl-Storable
34 BuildRequires:  perl-Test-Fatal
35 BuildRequires:  perl-Test-Simple >= 0.96
36 BuildRequires:  perl-Test-Requires
37 BuildRequires:  perl-Try-Tiny
38 BuildRequires:  perl-namespace-autoclean
39 %endif
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _noautoreq_perl DateTime::TimeZone.*
44
45 %description
46 This class is the base class for all time zone objects. A time zone is
47 represented internally as a set of observances, each of which
48 describes the offset from GMT for a given time period. Note that
49 without the "DateTime.pm" module, this module does not do much. It's
50 primary interface is through a "DateTime" object, and most users will
51 not need to directly use "DateTime::TimeZone" methods.
52
53 %description -l pl.UTF-8
54 Jest to klasa bazowa dla klas wszystkich obiektów stref czasowych.
55 Strefa czasowa jest reprezentowana przez zbiór reguł, z których każda
56 określa przesunięcie o zadany okres czasu w stosunku do czasu
57 uniwersalnego (GMT). Należy zwrócić uwagę, że bez modułu "DateTime.pm"
58 moduł ten nie jest w stanie wiele zdziałać. Jego podstawowym
59 interfejsem jest moduł "DateTime" i w większości przypadków nie ma
60 potrzeby bezpośredniego korzystania z metod "DateTime::TimeZone".
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-%{version}
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor
68
69 %{__make}
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes
85 %{perl_vendorlib}/DateTime/TimeZone.pm
86 %{perl_vendorlib}/DateTime/TimeZone
87 %{_mandir}/man3/DateTime::TimeZone*.3pm*
This page took 0.080502 seconds and 4 git commands to generate.