]> git.pld-linux.org Git - packages/perl-DateTime-TimeZone.git/blob - perl-DateTime-TimeZone.spec
- 0.46 (Epoch: 2 due 0.3801 being "newer"), generic URL
[packages/perl-DateTime-TimeZone.git] / perl-DateTime-TimeZone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DateTime
7 %define         pnam    TimeZone
8 Summary:        DateTime::TimeZone - time zone object base class and factory
9 Summary(pl):    DateTime::TimeZone - podstawowe klasy obiektowe do obs³ugi stref czasowych
10 Name:           perl-DateTime-TimeZone
11 Version:        0.46
12 Release:        1
13 Epoch:          2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  fe52d18c393d3e7841be0aba972e4e43
19 URL:            http://search.cpan.org/dist/DateTime-TimeZone/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 # most test skipped without DateTime >= 0.1501
25 BuildRequires:  perl-DateTime >= 0.15_01
26 BuildRequires:  perl-Params-Validate >= 0.72
27 %endif
28 Requires:       perl-Class-Singleton >= 1.03
29 Requires:       perl-Params-Validate >= 0.72
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This class is the base class for all time zone objects. A time
35 zone is represented internally as a set of observances, each
36 of which describes the offset from GMT for a given time period.
37 Note that without the "DateTime.pm" module, this module does not
38 do much. It's primary interface is through a "DateTime" object,
39 and most users will not need to directly use "DateTime::TimeZone"
40 methods.
41
42 %description -l pl
43 Jest to klasa bazowa dla klas wszystkich obiektów stref czasowych.
44 Strefa czasowa jest reprezentowana przez zbiór regu³, z których ka¿da
45 okre¶la przesuniêcie o zadany okres czasu w stosunku do czasu
46 uniwersalnego (GMT). Nale¿y zwróciæ uwagê, ¿e bez modu³u "DateTime.pm"
47 modu³ ten nie jest w stanie wiele zdzia³aæ. Jego podstawowym
48 interfejsem jest modu³ "DateTime" i w wiêkszo¶ci przypadków nie ma
49 potrzeby bezpo¶redniego korzystania z metod "DateTime::TimeZone".
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Build.PL \
56         installdirs=vendor \
57         destdir=$RPM_BUILD_ROOT
58 ./Build
59
60 %{?with_tests:./Build test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 ./Build install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %{perl_vendorlib}/DateTime/TimeZone*pm
73 %dir %{perl_vendorlib}/DateTime/TimeZone
74 %{perl_vendorlib}/DateTime/TimeZone/*.pm
75 %dir %{perl_vendorlib}/DateTime/TimeZone/Africa
76 %{perl_vendorlib}/DateTime/TimeZone/Africa/*.pm
77 %dir %{perl_vendorlib}/DateTime/TimeZone/Indian
78 %{perl_vendorlib}/DateTime/TimeZone/Indian/*.pm
79 %dir %{perl_vendorlib}/DateTime/TimeZone/Pacific
80 %{perl_vendorlib}/DateTime/TimeZone/Pacific/*.pm
81 %dir %{perl_vendorlib}/DateTime/TimeZone/Europe
82 %{perl_vendorlib}/DateTime/TimeZone/Europe/*.pm
83 %dir %{perl_vendorlib}/DateTime/TimeZone/Asia
84 %{perl_vendorlib}/DateTime/TimeZone/Asia/*.pm
85 %dir %{perl_vendorlib}/DateTime/TimeZone/America
86 %{perl_vendorlib}/DateTime/TimeZone/America/*.pm
87 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Argentina
88 %{perl_vendorlib}/DateTime/TimeZone/America/Argentina/*.pm
89 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Indiana
90 %{perl_vendorlib}/DateTime/TimeZone/America/Indiana/*.pm
91 %dir %{perl_vendorlib}/DateTime/TimeZone/America/Kentucky
92 %{perl_vendorlib}/DateTime/TimeZone/America/Kentucky/*.pm
93 %dir %{perl_vendorlib}/DateTime/TimeZone/America/North_Dakota
94 %{perl_vendorlib}/DateTime/TimeZone/America/North_Dakota/*.pm
95 %dir %{perl_vendorlib}/DateTime/TimeZone/Australia
96 %{perl_vendorlib}/DateTime/TimeZone/Australia/*.pm
97 %dir %{perl_vendorlib}/DateTime/TimeZone/Atlantic
98 %{perl_vendorlib}/DateTime/TimeZone/Atlantic/*.pm
99 %dir %{perl_vendorlib}/DateTime/TimeZone/Antarctica
100 %{perl_vendorlib}/DateTime/TimeZone/Antarctica/*.pm
101 %{_mandir}/man3/*
This page took 0.078671 seconds and 3 git commands to generate.