]> git.pld-linux.org Git - packages/perl-DBICx-TestDatabase.git/blob - perl-DBICx-TestDatabase.spec
- updated Source0 URL
[packages/perl-DBICx-TestDatabase.git] / perl-DBICx-TestDatabase.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DBICx
7 %define pnam    TestDatabase
8 Summary:        DBICx::TestDatabase - create a temporary database from a DBIx::Class::Schema
9 Summary(pl.UTF-8):      DBICx::TestDatabase - tworzy tymczasową bazę danych z DBIx::Class::Schema
10 Name:           perl-DBICx-TestDatabase
11 Version:        0.02
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/J/JR/JROCKWAY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e236d1a2bb4b07c70b35af0ae6e49415
18 URL:            http://search.cpan.org/dist/DBICx-TestDatabase/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DBD-SQLite
23 BuildRequires:  perl-DBIx-Class
24 BuildRequires:  perl-SQL-Translator
25 BuildRequires:  perl-Test-use-ok
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module creates a temporary SQLite database, deploys your DBIC
32 schema, and then connects to it. This lets you easily test your DBIC
33 schema. Since you have a fresh database for every test, you don't have
34 to worry about cleaning up after your tests, ordering of tests
35 affecting failure, etc.
36
37 %description -l pl.UTF-8
38 Moduł ten tworzy tymczasową bazę danych SQLite, osadza schemat DBIC i
39 wtedy łaczy się z nim.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/DBICx/*.pm
64 %{perl_vendorlib}/DBICx/TestDatabase
65 %{_mandir}/man3/*
This page took 0.054964 seconds and 3 git commands to generate.