]> git.pld-linux.org Git - packages/perl-DBD-PgPP.git/blob - perl-DBD-PgPP.spec
- generic URL
[packages/perl-DBD-PgPP.git] / perl-DBD-PgPP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires database connection)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    PgPP
8 Summary:        Pure Perl PostgresSQL driver for DBI
9 Summary(pl.UTF-8):      Czysto perlowy sterownik do PostgresSQL-a dla DBI
10 Name:           perl-DBD-PgPP
11 Version:        0.05
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  159d54a21eda08ab93fd44f2791cf56f
18 URL:            http://search.cpan.org/dist/DBD-PgPP/
19 BuildRequires:  perl-DBI
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBD::PgPP is a Pure Perl client interface for the PostgreSQL database.
27 This module implements the PostgreSQL client/server network protocol,
28 so you don't need an external PostgreSQL client library like "libpq"
29 for it to work. That means you can connect to a PostgreSQL server from
30 operating systems to which PostgreSQL has not been ported.
31
32 %description -l pl.UTF-8
33 DBD::PgPP to czysto perlowy interfejs kliencki do bazy danych
34 PostgreSQL. Ten moduł implementuje protokół sieciowy klient-serwer
35 PostgreSQL-a, więc nie wymaga do działania zewnętrznej biblioteki
36 klienckiej typu libpq. Oznacza to, że można się łączyć z serwerem
37 PostgreSQL z systemów operacyjnych, na które PostgreSQL nie został
38 sportowany.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 # Needed to be set for tests:
49 #PG_TEST_DB=<database>
50 #PG_TEST_USER=<user>
51 #PG_TEST_PASS=<password>
52 #PG_TEST_HOST=<hostname>*
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/DBD/PgPP.pm
68 %lang(ja) %{perl_vendorlib}/DBD/DBD-PgPP.ja.pod
69 %{_mandir}/man[13]/*
This page took 0.059249 seconds and 3 git commands to generate.