]> git.pld-linux.org Git - packages/perl-Crypt-SSLeay.git/blob - perl-Crypt-SSLeay.spec
- release 2 (by relup.sh)
[packages/perl-Crypt-SSLeay.git] / perl-Crypt-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    SSLeay
8 Summary:        Crypt::SSLeay - OpenSSL glue that provides LWP HTTPS support
9 Summary(cs.UTF-8):      Crypt::SSLeay - spojení OpenSSL, které poskytuje podporu HTTPS pro LWP
10 Summary(da.UTF-8):      Crypt::SSLeay - OpenSSL-klister som giver understøttelse for LWP HTTPS
11 Summary(de.UTF-8):      Crypt::SSLeay - OpenSSL Elemente für LWP HTTPS Support
12 Summary(es.UTF-8):      Crypt::SSLeay - Enlace OpenSSL que proporciona soporte HTTPS LWP
13 Summary(fr.UTF-8):      Crypt::SSLeay - colle OpenSSL fournissant une prise en charge LWP HTTPS
14 Summary(it.UTF-8):      Crypt::SSLeay - OpenSSL glue che fornisce supporto per LWP HTTPS
15 Summary(ja.UTF-8):      Crypt::SSLeay - LWP HTTPSのサポートを提供するOpenSSL glue
16 Summary(ko.UTF-8):      Crypt::SSLeay - LWP HTTPS 지원을 제공하는 OpenSSL 접착(glue) 입니다
17 Summary(pl.UTF-8):      Crypt::SSLeay - obsługa HTTPS dla LWP przez połączenie z OpenSSL
18 Summary(pt.UTF-8):      Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
19 Summary(pt_BR.UTF-8):   Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
20 Summary(sv.UTF-8):      Crypt::SSLeay - OpenSSL-klister som gör stöd för LWP HTTPS
21 Summary(tr.UTF-8):      Crypt::SSLeay - LWP HTTPS desteği sağlayan OpenSSL bağlantısı
22 Summary(zh_CN.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支持的 OpenSSL 胶水
23 Summary(zh_TW.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支援的 OpenSSL glue。
24 Name:           perl-Crypt-SSLeay
25 Version:        0.72
26 Release:        2
27 # same as perl
28 License:        GPL v1+ or Artistic
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
31 # Source0-md5:  77d955c9056dbb12413d95d8852a9cdf
32 URL:            http://search.cpan.org/dist/Crypt-SSLeay/
33 BuildRequires:  openssl-devel >= 0.9.7d
34 BuildRequires:  perl-ExtUtils-CBuilder >= 0.280205
35 BuildRequires:  perl-Path-Class >= 0.35
36 %if %{with tests}
37 BuildRequires:  perl-Test-Simple >= 0.88
38 BuildRequires:  perl-Try-Tiny >= 0.19
39 %endif
40 BuildRequires:  perl-devel >= 1:5.8.0
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 Conflicts:      perl-LWP-Protocol-https < 6.02
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 This perl module provides support for the HTTPS protocol under LWP,
47 so that a LWP::UserAgent can make HTTPS GET & HEAD & POST requests.
48
49 The Crypt::SSLeay package contains Net::SSL, which is automatically
50 loaded by LWP::Protocol::https on HTTPS requests, and provides the
51 necessary SSL glue for that module to work.
52
53 %description -l cs.UTF-8
54 Tento modul Perlu nabízí podporu pro protokol HTTPS pod LWP, takže
55 LWP::UserAgent může provádět HTTPS požadavky GET & HEAD & POST. Pro
56 informace o požadavcích POST si prosím přečtěte perldoc LWP.
57
58 Balíček Crypt::SSLeay obsahuje Net::SSL, který je automaticky nahrán
59 LWP::Protocol::https při požadavcích HTTPS, a nabízí potřebné spojení
60 SSL, aby tento modul fungoval.
61
62 %description -l da.UTF-8
63 Dette perlmodul giver understøttelse for protokollen HTTPS under LWP,
64 så en LWP::UserAgent kan lave HTTPS-forespørgslerne GET & HEAD & POST.
65 Se perldoc LWP for mere information om POST-forespørgsler.
66
67 Pakken Crypt::SSLeay indeholder Net::SSL som automatisk læses ind af
68 LWP::Protocol::https ved HTTPS-forespørgsler, og giver det nødvendige
69 SSL-klister til at det modul kan fungere.
70
71 %description -l de.UTF-8
72 Dieses Perl-Modul liefert Support für das HTTPS-Protokoll unter LWP,
73 so dass ein LWP::UserAgent HTTPS GET & HEAD & POST Anfragen ausführen
74 kann. Weitere Informationen über POST-Anfragen sindin perldoc LWP
75 enthalten.
76
77 Das Crypt::SSLeay Paket enthält Net::SSL, das bei HTTPS-Anfragen
78 automatisch von LWP::Protocol::https geladen wird, und bietet die
79 erforderlichen SSL-Elemente für das Modul.
80
81 %description -l es.UTF-8
82 Este módulo perl proporciona soporte para el protocolo HTTPS bajo LWP,
83 de manera que LWP::UserAgent pueda crear peticiones GET & HEAD & POST.
84 Consulte perldoc LWP para más información sobre las peticiones POST.
85
86 El paquete Crypt::SSLeay contiene Net::SSL, que se descarga
87 automáticamente por LWP::Protocol::https en las peticiones HTTPS y
88 proporciona los elementos necesarios SSL para que funcione el módulo.
89
90 %description -l fr.UTF-8
91 Le module perl fournit un support pour le protocole HTTPS sous LWP, de
92 manière à ce qu'un LWP::UserAgent puisse exécuter les requêtes GET &
93 HEAD & POST. Veuillez consulter perldoc LWP pour obtenir de plus
94 amples informations concernant les requêtes POST.
95
96 Le paquetage Crypt::SSLeay contient Net::SSL, qui est chargé
97 automatiquement par LWP::Protocol::https sur les requêtes HTTPS, et
98 fournit la colle SSL nécessaire pour faire fonctionner ce module.
99
100 %description -l it.UTF-8
101 Questo modulo di perl supporta il protocollo HTTPS in LWP, in modo che
102 un LWP::UserAgent possa effettuare richieste GET & HEAD & POST HTTP.
103 Consultare perldoc LWP per ulteriori informazioni sulle richieste
104 POST.
105
106 Il pacchetto Crypt::SSLeay contiene Net::SSL, che viene caricato
107 automaticamente da LWP::Protocol::https sulle richieste HTTP e
108 fornisce la colla SSL necessaria per far funzionare quel modulo.
109
110 %description -l ja.UTF-8
111 この perlモジュールは、LWPの元でHTTPSプロトコル用のサポートを提供しま
112 す。ですから、LWP::UserAgent は HTTPS GET & HEAD & POSTリクエストを
113 作成できます。 POSTリクエストの詳細については perldoc LWPを
114 御覧下さい。 理 末スト Crypt::SSLeayパッケージには、hリクエストにより
115 LWP::Protocol::https で自動的にロードされるNet::SSLを含んでいます。そ
116 して、モジュールが動作するよう に 必要なSSL glueを提供します。
117
118 %description -l ko.UTF-8
119 이 perl 모듈은 LWP::UserAgent가 HTTPS GET, HEAD, POST 요청을 생성할 수
120 있도록 LWP 하에서 HTTPS 프로토콜에 대한 지원을 제공합니다. POST 요청에
121 대한 보다 많은 정보를 원하시면, perldoc LWP를 참조하시기 바랍니다.
122
123 Crypt::SSLeay 패키지에는 HTTPS 요청에 따라 LWP::Protocol::https에 의해
124 자동으로 로딩되는 Net::SSL가 포함되어 있으며, 해당 모듈이 작동하는데
125 필요한 SSL 접착 (glue)을 제공합니다.
126
127 %description -l pl.UTF-8
128 Ten moduł Perla dostarcza obsługę protokołu HTTPS dla LWP, dzięki
129 czemu LWP::UserAgent może wykonywać zapytania GET i POST po HTTPS.
130
131 Pakiet Crypt::SSLeay zawiera moduł Net::SSL, automatycznie ładowany
132 przez LWP::Protocol::https w przypadku zapytań HTTPS, oraz dostarcza
133 niezbędnych do jego działania składników.
134
135 %description -l pt.UTF-8
136 Este módulo de Perl providencia o suporte para o protocolo HTTP em
137 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
138 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
139 os pedidos de POST.
140
141 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
142 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
143 fornece a lógica de interacção com o SSL necessária para o módulo
144 funcionar.
145
146 %description -l pt_BR.UTF-8
147 Este módulo de Perl providencia o suporte para o protocolo HTTP em
148 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
149 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
150 os pedidos de POST.
151
152 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
153 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
154 fornece a lógica de interacção com o SSL necessária para o módulo
155 funcionar.
156
157 %description -l sv.UTF-8
158 Denna perlmodul ger stöd för protokollet HTTPS under LWP, så att en
159 LWP::UserAgent kan göra HTTPS-begäran GET & HEAD & POST.  Se perldoc
160 LWP för mer information om POST-begäran.
161
162 Paketet Crypt::SSLeay innehåller Net::SSL som automatiskt läses in av
163 LWP::Protocol::https vid HTTPS-begäran, och ger det nödvändiga
164 SSL-klistret för att den mudulen skall fungera.
165
166 %description -l zh_CN.UTF-8
167 该 Perl 模块提供对 LWP 下的 HTTPS 协议的支持,因此
168  LWP::UserAgent 能够进行HTTPS GET & HEAD & POST
169 请求。请参阅 perldoc LWP 来获取关于 POST 请求的详
170 细信息。
171
172 Crypt::SSLeay 软件包包含 Net::SSL(它在 HTTPS 请求时
173 被 LWP::Protocol::https 自动载入),并且为该模块的运行
174 提供了必要的 SSL 胶水。
175
176 %prep
177 %setup -q -n %{pdir}-%{pnam}-%{version}
178
179 %build
180 yes "" | %{__perl} Makefile.PL \
181         INSTALLDIRS=vendor
182 %{__make} \
183         CC="%{__cc}" \
184         OPTIMIZE="%{rpmcflags}"
185
186 %{?with_tests:%{__make} test}
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc Changes TODO
200 %{perl_vendorarch}/Crypt/SSLeay.pm
201 %{perl_vendorarch}/Crypt/SSLeay
202 %{perl_vendorarch}/Net/SSL.pm
203 %dir %{perl_vendorarch}/auto/Crypt/SSLeay
204 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/SSLeay/SSLeay.so
205 %{_mandir}/man3/Crypt::SSLeay*.3pm*
206 %{_mandir}/man3/Net::SSL.3pm*
This page took 0.080458 seconds and 4 git commands to generate.