]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-ECDSA.git/blob - perl-Crypt-OpenSSL-ECDSA.spec
- initial version, 0.07
[packages/perl-Crypt-OpenSSL-ECDSA.git] / perl-Crypt-OpenSSL-ECDSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-ECDSA
8 Summary:        Crypt::OpenSSL::ECDSA - Perl extension for OpenSSL ECDSA (Elliptic Curve Digital Signature Algorithm)
9 Summary(pl.UTF-8):      Crypt::OpenSSL::ECDSA - implementacja algorytmu ECDSA w Perlu
10 Name:           perl-Crypt-OpenSSL-ECDSA
11 Version:        0.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2ee0afce54f5a2bfc47b336a7400eca2
18 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-ECDSA/
19 BuildRequires:  openssl-devel >= 0.9.8a
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Crypt-OpenSSL-EC >= 1.01
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides an interface to the ECDSA (Elliptic Curve Digital
29 Signature Algorithm) functions in OpenSSL. Tested against OpenSSL 1.0.2
30
31 %description -l pl.UTF-8
32 Ten moduÅ‚ dostarcza interfejs do funkcji implementujÄ…cych algorytm
33 ECDSA z biblioteki OpenSSL. Testowane z OpenSSLem w wersji 1.0.2.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Crypt/OpenSSL/ECDSA.pm
60 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA
61 %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/autosplit.ix
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/*.so
63 %{_mandir}/man3/Crypt::OpenSSL::ECDSA.3pm*
This page took 0.030958 seconds and 4 git commands to generate.