]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-ECDSA.git/blob - perl-Crypt-OpenSSL-ECDSA.spec
- updated URL
[packages/perl-Crypt-OpenSSL-ECDSA.git] / perl-Crypt-OpenSSL-ECDSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-ECDSA
7 Summary:        Crypt::OpenSSL::ECDSA - Perl extension for OpenSSL ECDSA (Elliptic Curve Digital Signature Algorithm)
8 Summary(pl.UTF-8):      Crypt::OpenSSL::ECDSA - implementacja algorytmu ECDSA w Perlu
9 Name:           perl-Crypt-OpenSSL-ECDSA
10 Version:        0.10
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  182eb2eec5f490f416358d4271fe2237
17 URL:            https://metacpan.org/dist/Crypt-OpenSSL-ECDSA
18 BuildRequires:  openssl-devel >= 0.9.8a
19 BuildRequires:  perl-devel >= 1:5.8.5
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Crypt-OpenSSL-EC >= 1.01
24 %endif
25 Requires:       perl-Crypt-OpenSSL-EC >= 1.01
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides an interface to the ECDSA (Elliptic Curve Digital
30 Signature Algorithm) functions in OpenSSL.
31
32 %description -l pl.UTF-8
33 Ten moduÅ‚ dostarcza interfejs do funkcji implementujÄ…cych algorytm
34 ECDSA z biblioteki OpenSSL.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/OpenSSL/ECDSA.pm
61 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA
62 %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/autosplit.ix
63 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/ECDSA.so
64 %{_mandir}/man3/Crypt::OpenSSL::ECDSA.3pm*
This page took 0.115637 seconds and 4 git commands to generate.