]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-ECDSA.git/blob - perl-Crypt-OpenSSL-ECDSA.spec
- rebuild with perl 5.30.0
[packages/perl-Crypt-OpenSSL-ECDSA.git] / perl-Crypt-OpenSSL-ECDSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-ECDSA
8 Summary:        Crypt::OpenSSL::ECDSA - Perl extension for OpenSSL ECDSA (Elliptic Curve Digital Signature Algorithm)
9 Summary(pl.UTF-8):      Crypt::OpenSSL::ECDSA - implementacja algorytmu ECDSA w Perlu
10 Name:           perl-Crypt-OpenSSL-ECDSA
11 Version:        0.07
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2ee0afce54f5a2bfc47b336a7400eca2
18 Patch0:         Crypt-OpenSSL-ECDSA-0.08-Port-to-OpenSSL-1.1.0.patch
19 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-ECDSA/
20 BuildRequires:  openssl-devel >= 0.9.8a
21 BuildRequires:  perl-devel >= 1:5.8.1
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Crypt-OpenSSL-EC >= 1.01
25 %endif
26 Requires:       perl-Crypt-OpenSSL-EC >= 1.01
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides an interface to the ECDSA (Elliptic Curve Digital
31 Signature Algorithm) functions in OpenSSL. Tested against OpenSSL 1.0.2
32
33 %description -l pl.UTF-8
34 Ten moduÅ‚ dostarcza interfejs do funkcji implementujÄ…cych algorytm
35 ECDSA z biblioteki OpenSSL. Testowane z OpenSSLem w wersji 1.0.2.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/Crypt/OpenSSL/ECDSA.pm
63 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA
64 %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/autosplit.ix
65 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/ECDSA/ECDSA.so
66 %{_mandir}/man3/Crypt::OpenSSL::ECDSA.3pm*
This page took 0.084805 seconds and 3 git commands to generate.