]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Bignum.git/blob - perl-Crypt-OpenSSL-Bignum.spec
- rel 2
[packages/perl-Crypt-OpenSSL-Bignum.git] / perl-Crypt-OpenSSL-Bignum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-Bignum
8 Summary:        Crypt::OpenSSL::Bignum - OpenSSL's multiprecision integer arithmetic
9 Summary(pl.UTF-8):      Crypt::OpenSSL::Bignum - arytmetyka liczb całkowitych dużej precyzji z OpenSSL
10 Name:           perl-Crypt-OpenSSL-Bignum
11 Version:        0.03
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b526c1554b2f3bf7d94bf0c8c474fd2d
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::OpenSSL::Bignum provides access to OpenSSL multiprecision
25 integer arithmetic libraries. Presently, many though not all of the
26 arithmetic operations that OpenSSL provides are exposed to Perl. In
27 addition, this module can be used to provide access to bignum values
28 produced by other OpenSSL modules, such as key parameters from
29 Crypt::OpenSSL::RSA.
30
31 %description -l pl.UTF-8
32 Crypt::OpenSSL::Bignum daje dostęp do bibliotek arytmetyki
33 liczb całkowitych dużej precyzji z OpenSSL. Aktualnie wiele, ale nie
34 wszystkie, operacje arytmetyczne udostępniane przez OpenSSL są
35 dostępne z Perla. Ponadto ten moduł może być używany do udostępnienia
36 dużych wartości produkowanych przez inne moduły OpenSSL, takie jak
37 parametry klucza z Crypt::OpenSSL::RSA.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorarch}/Crypt/OpenSSL/Bignum.pm
64 %{perl_vendorarch}/Crypt/OpenSSL/Bignum
65 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum
66 %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.bs
67 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.so
68 %{_mandir}/man3/*
This page took 0.059316 seconds and 4 git commands to generate.