]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Bignum.git/blob - perl-Crypt-OpenSSL-Bignum.spec
- updated URL
[packages/perl-Crypt-OpenSSL-Bignum.git] / perl-Crypt-OpenSSL-Bignum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Crypt
6 %define         pnam    OpenSSL-Bignum
7 Summary:        Crypt::OpenSSL::Bignum - OpenSSL's multiprecision integer arithmetic
8 Summary(pl.UTF-8):      Crypt::OpenSSL::Bignum - arytmetyka liczb całkowitych dużej precyzji z OpenSSL
9 Name:           perl-Crypt-OpenSSL-Bignum
10 Version:        0.09
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c8ae05771c70c69b3e5647b29a885ed2
17 Patch0:         %{name}-mod_sqrt.patch
18 URL:            https://metacpan.org/dist/Crypt-OpenSSL-Bignum
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Crypt::OpenSSL::Bignum provides access to OpenSSL multiprecision
27 integer arithmetic libraries. Presently, many though not all of the
28 arithmetic operations that OpenSSL provides are exposed to Perl. In
29 addition, this module can be used to provide access to bignum values
30 produced by other OpenSSL modules, such as key parameters from
31 Crypt::OpenSSL::RSA.
32
33 %description -l pl.UTF-8
34 Crypt::OpenSSL::Bignum daje dostęp do bibliotek arytmetyki
35 liczb całkowitych dużej precyzji z OpenSSL. Aktualnie wiele, ale nie
36 wszystkie, operacje arytmetyczne udostępniane przez OpenSSL są
37 dostępne z Perla. Ponadto ten moduł może być używany do udostępnienia
38 dużych wartości produkowanych przez inne moduły OpenSSL, takie jak
39 parametry klucza z Crypt::OpenSSL::RSA.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43 %patch0 -p1
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Crypt/OpenSSL/Bignum.pm
67 %{perl_vendorarch}/Crypt/OpenSSL/Bignum
68 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum
69 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.so
70 %{_mandir}/man3/Crypt::OpenSSL::Bignum*.3pm*
This page took 0.107126 seconds and 4 git commands to generate.