]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Bignum.git/blob - perl-Crypt-OpenSSL-Bignum.spec
- new bconds
[packages/perl-Crypt-OpenSSL-Bignum.git] / perl-Crypt-OpenSSL-Bignum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-Bignum
8 Summary:        Crypt::OpenSSL::Bignum - OpenSSL's multiprecision integer arithmetic
9 Summary(pl):    Crypt::OpenSSL::Bignum - arytmetyka liczb ca³kowitych du¿ej precyzji z OpenSSL
10 Name:           perl-Crypt-OpenSSL-Bignum
11 Version:        0.03
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b526c1554b2f3bf7d94bf0c8c474fd2d
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  perl-devel >= 5.6.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::OpenSSL::Bignum provides access to OpenSSL multiprecision
25 integer arithmetic libraries. Presently, many though not all of the
26 arithmetic operations that OpenSSL provides are exposed to Perl. In
27 addition, this module can be used to provide access to bignum values
28 produced by other OpenSSL modules, such as key parameters from
29 Crypt::OpenSSL::RSA.
30
31 %description -l pl
32 Crypt::OpenSSL::Bignum daje dostêp do bibliotek arytmetyki
33 liczb ca³kowitych du¿ej precyzji z OpenSSL. Aktualnie wiele, ale nie
34 wszystkie, operacje arytmetyczne udostêpniane przez OpenSSL s±
35 dostêpne z Perla. Ponadto ten modu³ mo¿e byæ u¿ywany do udostêpnienia
36 du¿ych warto¶ci produkowanych przez inne modu³y OpenSSL, takie jak
37 parametry klucza z Crypt::OpenSSL::RSA.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Crypt/OpenSSL/Bignum.pm
61 %{perl_vendorarch}/Crypt/OpenSSL/Bignum
62 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum
63 %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.so
65 %{_mandir}/man3/*
This page took 0.064553 seconds and 4 git commands to generate.