]> git.pld-linux.org Git - packages/perl-Crypt-OpenSSL-Bignum.git/blob - perl-Crypt-OpenSSL-Bignum.spec
- removed zero-sized .bs file
[packages/perl-Crypt-OpenSSL-Bignum.git] / perl-Crypt-OpenSSL-Bignum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    OpenSSL-Bignum
8 Summary:        Crypt::OpenSSL::Bignum - OpenSSL's multiprecision integer arithmetic
9 Summary(pl.UTF-8):      Crypt::OpenSSL::Bignum - arytmetyka liczb całkowitych dużej precyzji z OpenSSL
10 Name:           perl-Crypt-OpenSSL-Bignum
11 Version:        0.04
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9369ef722b0705c0604998559988eb18
18 URL:            http://search.cpan.org/dist/Crypt-OpenSSL-Bignum/
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Crypt::OpenSSL::Bignum provides access to OpenSSL multiprecision
26 integer arithmetic libraries. Presently, many though not all of the
27 arithmetic operations that OpenSSL provides are exposed to Perl. In
28 addition, this module can be used to provide access to bignum values
29 produced by other OpenSSL modules, such as key parameters from
30 Crypt::OpenSSL::RSA.
31
32 %description -l pl.UTF-8
33 Crypt::OpenSSL::Bignum daje dostęp do bibliotek arytmetyki
34 liczb całkowitych dużej precyzji z OpenSSL. Aktualnie wiele, ale nie
35 wszystkie, operacje arytmetyczne udostępniane przez OpenSSL są
36 dostępne z Perla. Ponadto ten moduł może być używany do udostępnienia
37 dużych wartości produkowanych przez inne moduły OpenSSL, takie jak
38 parametry klucza z Crypt::OpenSSL::RSA.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorarch}/Crypt/OpenSSL/Bignum.pm
65 %{perl_vendorarch}/Crypt/OpenSSL/Bignum
66 %dir %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum
67 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/OpenSSL/Bignum/Bignum.so
68 %{_mandir}/man3/Crypt::OpenSSL::Bignum*.3pm*
This page took 0.063417 seconds and 4 git commands to generate.