]> git.pld-linux.org Git - packages/perl-Config-Simple.git/blob - perl-Config-Simple.spec
- cosmetics: unification
[packages/perl-Config-Simple.git] / perl-Config-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Config
7 %define pnam    Simple
8 Summary:        Config::Simple - simple configuration file class
9 Summary(pl):    Config::Simple - prosta klasa do obs³ugi plików konfiguracyjnych
10 Name:           perl-Config-Simple
11 Version:        4.55
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7ce4d142bbb399a838e5370f2c1c1b4a
18 BuildRequires:  perl-devel >= 5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Config::Simple is a class representing configuration file object. It
25 supports several configuration file syntax and tries to identify the
26 file syntax to parse them accordingly. Library supports parsing,
27 updating and creating configuration files.
28
29 %description -l pl
30 Config::Simple stanowi klasê reprezentuj±c± obiekty plików
31 konfiguracyjnych. Zawiera wsparcie dla kilku sk³adni plików
32 konfiguracyjnych a próbuje zidentyfikowaæ rodzaj u¿ywanej w danym
33 pliku sk³adni poprzez kolejne próby ich analizy. Biblioteka wspiera
34 analizê, aktualizacjê i tworzenie plików konfiguracyjnych.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/Config/Simple.pm
57 %{perl_vendorlib}/auto/Config/Simple
58 %{_mandir}/man3/*
This page took 0.029126 seconds and 3 git commands to generate.