]> git.pld-linux.org Git - packages/perl-Config-Simple.git/blob - perl-Config-Simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Config-Simple.git] / perl-Config-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Config
6 %define         pnam    Simple
7 Summary:        Config::Simple - simple configuration file class
8 Summary(pl.UTF-8):      Config::Simple - prosta klasa do obsługi plików konfiguracyjnych
9 Name:           perl-Config-Simple
10 Version:        4.59
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Config/SHERZODR/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  96513b61c7db591339ce2577878a3b32
17 URL:            http://search.cpan.org/dist/Config-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Config::Simple is a class representing configuration file object. It
25 supports several configuration file syntax and tries to identify the
26 file syntax to parse them accordingly. Library supports parsing,
27 updating and creating configuration files.
28
29 %description -l pl.UTF-8
30 Config::Simple stanowi klasę reprezentującą obiekty plików
31 konfiguracyjnych. Zawiera wsparcie dla kilku składni plików
32 konfiguracyjnych a próbuje zidentyfikować rodzaj używanej w danym
33 pliku składni poprzez kolejne próby ich analizy. Biblioteka wspiera
34 analizę, aktualizację i tworzenie plików konfiguracyjnych.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/Config/Simple.pm
57 %{perl_vendorlib}/auto/Config/Simple
58 %{_mandir}/man3/Config::Simple.3pm*
This page took 0.062039 seconds and 4 git commands to generate.