]> git.pld-linux.org Git - packages/perl-Clone.git/blob - perl-Clone.spec
initial, nfy
[packages/perl-Clone.git] / perl-Clone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Clone
7 Summary:        Clone - recursively copy Perl datatypes
8 Name:           perl-Clone
9 Version:        0.15
10 Release:        1
11 # as perl itself
12 License:        GPL or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  5cac94da96835758462133f3afd8fe22
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This module provides a clone() method which makes recursive copies
22 of nested hash, array, scalar and reference types, including tied
23 variables and objects.
24
25 %prep
26 %setup -q -n %{pdir}-%{version}
27
28 %build
29 %{__perl} Makefile.PL \
30         INSTALLDIRS=vendor
31
32 %{__make} \
33         OPTIMIZE="%{rpmcflags}"
34
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc Changes
49 %{perl_vendorarch}/Clone.pm
50 %{perl_vendorarch}/auto/Clone/Clone.bs
51 %attr(755,root,root) %{perl_vendorarch}/auto/Clone/Clone.so
52 %{_mandir}/man3/*
This page took 0.048007 seconds and 3 git commands to generate.