]> git.pld-linux.org Git - packages/perl-Archive-Zip.git/blob - perl-Archive-Zip.spec
- should be ready for perl-5.8.0; release++
[packages/perl-Archive-Zip.git] / perl-Archive-Zip.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Archive
7 %define         pnam    Zip
8 Summary:        Archive::Zip - module for manipulation of ZIP archives
9 Summary(pl):    Archive::Zip - modu³ do manipulacji archiwami ZIP
10 Name:           perl-Archive-Zip
11 Version:        1.05
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Compress-Zlib >= 1.14
19 %endif
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Archive::Zip module allows a Perl program to create, manipulate,
26 read, and write ZIP archive files.
27
28 %description -l pl
29 Modu³ Archive::Zip udostêpnia programom w Perlu mo¿liwo¶æ tworzenia,
30 manipulowania, czytania i zapisywania archiwów ZIP.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor 
38 %{__make}
39
40 %{!?_without_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_bindir}
45
46 %{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Change* README TODO docs/*
57 %attr(755,root,root) %{_bindir}/crc32
58 %dir %{perl_vendorlib}/Archive/Zip
59 %{perl_vendorlib}/Archive/Zip/*.pm
60 %{perl_vendorlib}/Archive/Zip.pm
61 %{_examplesdir}/%{name}-%{version}
62 %{_mandir}/man3/*
This page took 0.039426 seconds and 3 git commands to generate.