]> git.pld-linux.org Git - packages/perl-Archive-Zip.git/blob - perl-Archive-Zip.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Archive-Zip.git] / perl-Archive-Zip.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Archive
6 %define         pnam    Zip
7 Summary:        Archive::Zip - module for manipulation of ZIP archives
8 Summary(pl.UTF-8):      Archive::Zip - moduł do manipulacji archiwami ZIP
9 Name:           perl-Archive-Zip
10 Version:        1.64
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Archive/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  684da165168700f6e37d116431776aba
17 URL:            http://search.cpan.org/dist/Archive-Zip/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl(File::Spec) >= 0.80
21 BuildRequires:  perl-Compress-Raw-Zlib >= 2.017
22 BuildRequires:  perl-File-Which >= 0.05
23 BuildRequires:  perl-IO-Compress
24 BuildRequires:  perl-Test-MockModule
25 BuildRequires:  perl-Test-Simple >= 0.88
26 %endif
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The Archive::Zip module allows a Perl program to create, manipulate,
33 read, and write ZIP archive files.
34
35 %description -l pl.UTF-8
36 Moduł Archive::Zip udostępnia programom w Perlu możliwość tworzenia,
37 manipulowania, czytania i zapisywania archiwów ZIP.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_bindir}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Archive/Zip/FAQ.pod
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %attr(755,root,root) %{_bindir}/crc32
68 %dir %{perl_vendorlib}/Archive/Zip
69 %{perl_vendorlib}/Archive/Zip/*.pm
70 %{perl_vendorlib}/Archive/Zip.pm
71 %{_examplesdir}/%{name}-%{version}
72 %{_mandir}/man3/Archive::Zip*.3pm*
This page took 0.078202 seconds and 4 git commands to generate.